Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1693186 - No sound on Realtek S1220A (MBO: Asus Prime X370-Pro)
Summary: No sound on Realtek S1220A (MBO: Asus Prime X370-Pro)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-27 10:05 UTC by Ueli Hugenschmidt
Modified: 2019-03-29 10:50 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-29 10:49:52 UTC


Attachments (Terms of Use)
result of: # journalctl --no-hostname -k > dmesg.txt (deleted)
2019-03-27 10:05 UTC, Ueli Hugenschmidt
no flags Details

Description Ueli Hugenschmidt 2019-03-27 10:05:24 UTC
Created attachment 1548488 [details]
result of: # journalctl --no-hostname -k > dmesg.txt

1. Please describe the problem:
no sound since the latest one or two kernel releases

2. What is the Version-Release number of the kernel:
4.20.16-100.fc28.x86_64

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :
don't remember if it still worked on 4.20.15-100
if I remember correctly, with kernel 4.20.15-100 there was an issue with recompiling vmware modules

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
e.g. play a youtube clip


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
==> does not work out of the box:

warning: /var/cache/dnf/rawhide-2d95c80a1fa0a67d/packages/kernel-core-5.1.0-0.rc1.git2.1.fc31.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 3c3359c4: NOKEY
Importing GPG key 0x9DB62FB1:
 Userid     : "Fedora 28 (28) <fedora-28@fedoraproject.org>"
 Fingerprint: 128C F232 A937 1991 C8A6 5695 E08E 7E62 9DB6 2FB1
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
Is this ok [y/N]: y
Key imported successfully
Import of key(s) didn't help, wrong key(s)?
Public key for kernel-core-5.1.0-0.rc1.git2.1.fc31.x86_64.rpm is not installed. Failing package is: kernel-core-5.1.0-0.rc1.git2.1.fc31.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
Public key for kernel-5.1.0-0.rc1.git2.1.fc31.x86_64.rpm is not installed. Failing package is: kernel-5.1.0-0.rc1.git2.1.fc31.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
Public key for kernel-modules-5.1.0-0.rc1.git2.1.fc31.x86_64.rpm is not installed. Failing package is: kernel-modules-5.1.0-0.rc1.git2.1.fc31.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: GPG check FAILED


6. Are you running any modules that not shipped with directly Fedora's kernel?:
I don't understand: do you mean, whether I use pkgs that are not from fc28 repos?
s6> dnf repolist
...
Failed to synchronize cache for repo 'nuxref-shared', disabling.
Last metadata expiration check: 0:00:00 ago on Wed 27 Mar 2019 10:59:26 AM CET.
repo id                                  repo name                                                  status
*fedora                                  Fedora 28 - x86_64                                         57,327
google-chrome                            google-chrome                                                   3
nuxref                                   RHEL 28 - nuxref.com                                           23
rpm-sphere                               RPM Sphere                                                 10,717
*rpmfusion-free                          RPM Fusion for Fedora 28 - Free                               563
*rpmfusion-free-updates                  RPM Fusion for Fedora 28 - Free - Updates                     280
*rpmfusion-nonfree-nvidia-driver         RPM Fusion for Fedora 28 - Nonfree - NVIDIA Driver             15
*updates                                 Fedora 28 - x86_64 - Updates                               21,633


7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 Ueli Hugenschmidt 2019-03-27 15:58:18 UTC
meanwhile kernel 5.1.0-0.rc1.git2.1.fc31.x86_64 installed from rawhide (--nogpg switch): still no sound. 
External music amplifier & wire checked (50 Hz buzz) and MP3 player.

Comment 2 Ueli Hugenschmidt 2019-03-29 10:49:52 UTC
no kernel problem but a mis-configured sound: using /usr/bin/pavucontrol helped.

finally found: https://opensource.com/article/17/1/linux-plays-sound


Note You need to log in before you can comment on or make changes to this bug.