Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1693158 - It throws an exception while creating a bug with non-exist component by xml-rpc
Summary: It throws an exception while creating a bug with non-exist component by xml-rpc
Keywords:
Status: CLOSED DUPLICATE of bug 1679385
Alias: None
Product: Bugzilla
Classification: Community
Component: WebService
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-27 09:15 UTC by Rony Gong 🔥
Modified: 2019-03-27 10:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-27 10:14:47 UTC


Attachments (Terms of Use)

Description Rony Gong 🔥 2019-03-27 09:15:57 UTC
Description of problem:
It throws an exception while creating a bug with non-exist component by xml-rpc

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
{'fault_code': -32000,
 'fault_string': 'Can\'t call method "sub_component_count" on an undefined value at /var/www/html/bugzilla/extensions/SubComponents/Extension.pm line 931.\n'}

Expected results:
{'fault_code': 51,
 'fault_string': "There is no component named 'bne-test' in the 'Bugzilla' product."}

Additional info:

Comment 1 Jeff Fearn 🐞 2019-03-27 10:14:47 UTC

*** This bug has been marked as a duplicate of bug 1679385 ***


Note You need to log in before you can comment on or make changes to this bug.