Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1692959 - build: link libgfrpc with MATH_LIB (libm, -lm)
Summary: build: link libgfrpc with MATH_LIB (libm, -lm)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: 5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1692957
Blocks: glusterfs-5.6
TreeView+ depends on / blocked
 
Reported: 2019-03-26 18:08 UTC by Kaleb KEITHLEY
Modified: 2019-03-28 12:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1692957
Environment:
Last Closed: 2019-03-28 12:38:28 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22422 None Abandoned build: link libgfrpc with MATH_LIB (libm, -lm) 2019-03-28 12:38:12 UTC

Description Kaleb KEITHLEY 2019-03-26 18:08:06 UTC
+++ This bug was initially created as a clone of Bug #1692957 +++

Description of problem:

tl;dnr: libgfrpc.so calls log2(3) from libm; it should be explicitly
linked with -lm

the autoconf/automake/libtool stack is more or less forgiving on
different distributions. On forgiving systems libtool will semi-
magically link with implicit dependencies. But on Ubuntu, which
seems to be tending toward being less forgiving, the link of libgfrpc
will fail with an unresolved referencee to log2(3).


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2019-03-26 18:13:40 UTC
REVIEW: https://review.gluster.org/22422 (build: link libgfrpc with MATH_LIB (libm, -lm)) posted (#1) for review on release-5 by Kaleb KEITHLEY


Note You need to log in before you can comment on or make changes to this bug.