Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1692683 - subscription page and repository page are empty on webUI of Satellite6.5-snapshot21.0
Summary: subscription page and repository page are empty on webUI of Satellite6.5-snap...
Keywords:
Status: CLOSED DUPLICATE of bug 1692009
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Foreman Maintain
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Anurag Patel
QA Contact: Nikhil Kathole
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-26 08:50 UTC by qianzhan
Modified: 2019-03-26 08:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-26 08:52:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description qianzhan 2019-03-26 08:50:51 UTC
Description of problem:
subscription page and repository page are empty on webUI of Satellite6.5-snapshot21.0


Version-Release number of selected component (if applicable):

foreman-1.20.1.29-1.el7sat.noarch
rubygem-foreman_maintain-0.3.2-1.el7sat.noarch

How reproducible:
always

Steps to Reproduce:
1. Deploy Satellite6.5-snapshot21.0, and import manifest.
2. Check available subscriptions on Satellite6.5 in CLI:

[root@ent-01-vm-01 ~]# hammer subscription list --organization-label=Default_Organization
---|----------------------------------|----------------------------------------------------------------------------------|----------|----------|---------|--------------|---------------------|----------|---------
ID | UUID                             | NAME                                                                             | TYPE     | CONTRACT | ACCOUNT | SUPPORT      | END DATE            | QUANTITY | CONSUMED
---|----------------------------------|----------------------------------------------------------------------------------|----------|----------|---------|--------------|---------------------|----------|---------
24 | 8ac213b069b8a1d70169b8d1de7300e8 | CloudForms (10-pack)                                                             | Physical | 11844897 | 6190160 | Premium      | 2020/01/29 23:59:59 | 30       | 0       
21 | 8ac213b069b8a1d70169b8d1dd5600cf | Red Hat Beta Access                                                              | Physical | 11844894 | 6190160 | Self-Support | 2020/01/29 23:59:59 | 30       | 0       
32 | 8ac213b069b8a1d70169b8d1dfe000f7 | Red Hat Desktop (Extension Pack) (50 Entitlements)                               | Physical | 11844889 | 6190160 | Self-Support | 2020/01/29 23:59:59 | 30       | 0       
28 | 8ac213b069b8a1d70169b8d1e2a00118 | Red Hat Enterprise Linux Desktop + Workstation option, Premium                   | Physical | 11844890 | 6190160 | Premium      | 2020/01/29 23:59:59 | 30       | 0       
27 | 8ac213b069b8a1d70169b8d1e2df011c | Red Hat Enterprise Linux for HPC Compute Nodes, L3 (up to 4 sockets) 8 Nodes     | Physical | 11844887 | 6190160 | Basic        | 2020/01/29 23:59:59 | 30       | 0       
22 | 8ac213b069b8a1d70169b8d1ddb700dc | Red Hat Enterprise Linux for IBM System z, Premium                               | Physical | 11844888 | 6190160 | Premium      | 2020/01/29 23:59:59 | 30       | 0       
30 | 8ac213b069b8a1d70169b8d1e09d010b | Red Hat Enterprise Linux for Power, LE, Premium (4 Cores, Up to 4 LPARs)         | Physical | 11844891 | 6190160 | Premium      | 2020/01/29 23:59:59 | 30       | 0       
31 | 8ac213b069b8a1d70169b8d1e04800fb | Red Hat Enterprise Linux High Touch Beta                                         | Physical | 11844896 | 6190160 | Self-Support | 2020/01/29 23:59:59 | 30       | 0       
33 | 8ac213b069b8a1d70169b8d1df7000f0 | Red Hat Enterprise Linux, Premium (up to 2 sockets for POWER)                    | Physical | 11844884 | 6190160 | Premium      | 2020/01/29 23:59:59 | 30       | 0       
29 | 8ac213b069b8a1d70169b8d1e2330111 | Red Hat Enterprise Linux Server for HPC Compute Node, Self-support (8 sockets... | Physical | 11844886 | 6190160 | Self-Support | 2020/01/29 23:59:59 | 30       | 0       
23 | 8ac213b069b8a1d70169b8d1de1c00e2 | Red Hat Enterprise Linux Server, Premium (Physical or Virtual Nodes)             | Physical | 11844895 | 6190160 | Premium      | 2020/01/29 23:59:59 | 30       | 0       
26 | 8ac213b069b8a1d70169b8d1e38c0120 | Red Hat Enterprise Virtualization for Servers (1 Socket), Standard               | Physical | 11844892 | 6190160 | Standard     | 2020/01/29 23:59:59 | 30       | 0       
25 | 8ac213b069b8a1d70169b8d1dec400ec | Red Hat Satellite Infrastructure Subscription                                    | Physical | 11844893 | 6190160 | Premium      | 2020/01/29 23:59:59 | 30       | 0       
---|----------------------------------|----------------------------------------------------------------------------------|----------|----------|---------|--------------|---------------------|----------|---------


3. Check available subscriptions on Satellite6.5 webUI by clicking Content => Subscriptions: 
The subscription page is empty, and please refer attachment 'sat6.5_subscription_page_is_empty.png'

4. Check available repository-set on Satellite6.5 in CLI:
[root@ent-01-vm-01 ~]# hammer repository-set list --organization-label=Default_Organization
-----|-----------|---------------------------------------------------------------------------------
ID   | TYPE      | NAME
-----|-----------|---------------------------------------------------------------------------------
5565 | yum       | dotNET on RHEL Beta Debug RPMs for Red Hat Enterprise Linux 7 ComputeNode
4935 | yum       | dotNET on RHEL Beta Debug RPMs for Red Hat Enterprise Linux 7 Server
5570 | file      | dotNET on RHEL Beta (ISOs) for Red Hat Enterprise Linux 7 ComputeNode
4942 | file      | dotNET on RHEL Beta (ISOs) for Red Hat Enterprise Linux 7 Server
5564 | yum       | dotNET on RHEL Beta RPMs for Red Hat Enterprise Linux 7 ComputeNode
4934 | yum       | dotNET on RHEL Beta RPMs for Red Hat Enterprise Linux 7 Server
5566 | yum       | dotNET on RHEL Beta Source RPMs for Red Hat Enterprise Linux 7 ComputeNode

...


3328 | yum       | RHN Tools for Red Hat Enterprise Linux 7 Server (Source RPMs)                   
3361 | yum       | RHN Tools for Red Hat Enterprise Linux 7 Workstation Beta (Debug RPMs)          
3363 | yum       | RHN Tools for Red Hat Enterprise Linux 7 Workstation Beta (RPMs)                
3364 | yum       | RHN Tools for Red Hat Enterprise Linux 7 Workstation Beta (Source RPMs)         
3357 | yum       | RHN Tools for Red Hat Enterprise Linux 7 Workstation (Debug RPMs)               
3359 | yum       | RHN Tools for Red Hat Enterprise Linux 7 Workstation (RPMs)                     
3360 | yum       | RHN Tools for Red Hat Enterprise Linux 7 Workstation (Source RPMs)

5. Check available repository-set on Satellite6.5 webUI by clicking Content => Red Hat Repositories: 
The 'Red Hat Repositories' page is empty, and please refer attachment 'sat6.5_repository_page_is_empty.png'

Actual results:
As step 3 and step 5, subscription page and repository page are empty.

Expected results:
subscription page and repository page should not be empty

Additional info:

Comment 5 Nikhil Kathole 2019-03-26 08:52:55 UTC

*** This bug has been marked as a duplicate of bug 1692009 ***


Note You need to log in before you can comment on or make changes to this bug.