Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1692656 - The API of API federation can be enabled too, so we can get an API like federatedfederated..........API
Summary: The API of API federation can be enabled too, so we can get an API like feder...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Federation
Version: 4.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.2.0
Assignee: Paul Morie
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-26 07:09 UTC by Qin Ping
Modified: 2019-04-10 21:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-10 21:48:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Qin Ping 2019-03-26 07:09:44 UTC
Description of problem:
The API of API federation can be enabled too, so we can get an API like federatedfederated..........API


Version-Release number of selected component (if applicable):
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-03-25-180911   True        False         57m       Cluster version is 4.0.0-0.nightly-2019-03-25-180911

kubefed2 version: version.Info{Version:"0.0.6", GitCommit:"de6a0a909418f5ddf2d04d232b0ca55aa9cffb49", GitTreeState:"clean", BuildDate:"2019-03-14T00:43:37Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}

Federation v2 controller-manager version: version.Info{Version:"0.0.6", GitCommit:"de6a0a909418f5ddf2d04d232b0ca55aa9cffb49", GitTreeState:"clean", BuildDate:"2019-03-14T00:43:37Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}


How reproducible:
100%


Steps to Reproduce:
1. Install a namespace scoped federation controller manager
2. Join a cluster to a federation
3. Enable API(FederatedTypeConfig) federation with cmd:
./kubefed2 enable FederatedTypeConfig
4. Enable API(FederatedFederatedTypeConfig) federation with cmd:
./kubefed2 enable FederatedFederatedTypeConfig

Actual results:
All APIs federation enabled successfully.

Expected results:
How about federated APIs do not support federation.

Additional info:

Comment 1 Paul Morie 2019-03-28 04:25:24 UTC
I do not want to rule this out as a possibility :) But I don't want to support it either at this point.

Comment 2 Maru Newby 2019-04-10 18:18:32 UTC
This is not a bug.  kubefed is intended to support federation of any type.


Note You need to log in before you can comment on or make changes to this bug.