Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1692643 - Some videos of twitter fails to play
Summary: Some videos of twitter fails to play
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-26 06:10 UTC by Akarshan Biswas
Modified: 2019-04-06 12:28 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-06 12:28:52 UTC


Attachments (Terms of Use)

Description Akarshan Biswas 2019-03-26 06:10:11 UTC
Description of problem:
Almost everytime twitter videos on the twitter feed fails to play. Spamming the replay button does not help.

Version-Release number of selected component (if applicable):
66.0-9.fc29

How reproducible:
Randomly (Not always)

Steps to Reproduce:
1. Try to play a video on twitter
2.
3.

Actual results:
Video doesn't play

Expected results:
video should play as in other browsers

Additional info:
I got this JSON info from an addon:
"MediaInfo":{
"HTMLMediaElement":{
"autoplay":false
"buffered":[]
"controls":false
"crossOrigin":NULL
"currentSrc":"blob:https://twitter.com/d785d16b-71ad-4d7e-a905-d0fcde4fcfe0"
"currentTime":0
"defaultMuted":false
"defaultPlaybackRate":1
"duration":57.072993
"ended":false
"error":NULL
"loop":false
"mozAudioCaptured":false
"mozFragmentEnd":57.072993
"muted":false
"networkState":2
"networkState_name":"NETWORK_LOADING"
"paused":true
"playbackRate":1
"played":[]
"preload":"none"
"readyState":1
"seekable":[
0:{
"start":0
"end":57.072993
}
]
"seeking":false
"src":"blob:https://twitter.com/d785d16b-71ad-4d7e-a905-d0fcde4fcfe0"
"srcObject":NULL
"volume":1
}
"HTMLVideoElement":{
"height":0
"mozDecodedFrames":0
"mozFrameDelay":0
"mozHasAudio":true
"mozPaintedFrames":0
"mozParsedFrames":0
"mozPresentedFrames":0
"videoHeight":360
"videoWidth":640
"width":0
}
"videoPlaybackQuality":{
"ratio":"--"
"droppedVideoFrames":0
"corruptedVideoFrames":0
}
"mozMediaSourceObject":[
0:{
"sourceBuffers":[
0:{
"start":0.073333
"end":3.091927
}
]
}
1:{
"sourceBuffers":[]
}
]
"debugInfo":{
"Container Type":"MediaSource"
"Audio Decoder(audio/mp4a-latm, 2 channels @ 44.1kHz)":"ffmpeg audio decoder"
"Audio Frames Decoded":"1"
"Audio State":"ni=0 no=0 wp=0 demuxr=0 demuxq=0 decoder=0 tt=-1.0 tths=-1 in=1 out=1 qs=0 pending=0 wfd=0 eos=0 ds=0 wfk=0 sid=100"
"Video Decoder(video/avc, 640x360 @ 0.00)":"shutdown"
"Hardware Video Decoding":"disabled"
"Video Frames Decoded":"0 (skipped=0)"
"Video State":"ni=0 no=0 wp=1 demuxr=0 demuxq=0 decoder=0 tt=-1.0 tths=-1 in=0 out=0 qs=0 pending:0 wfd=1 eos=0 ds=0 wfk=0 sid=4294967295"
"Dumping Data for Demuxer":"7f2b11a48400"
"Dumping Audio Track Buffer(audio/mp4)":"mLastAudioTime=0.096553"
"Audio Track Buffer Details":"NumSamples=130 Size=67160 Evictable=0 NextGetSampleIndex=1 NextInsertionIndex=130"
"Audio Track Buffered":"ranges=[(0.073333, 3.091927)]"
"Dumping Video Track Buffer(video/mp4)":"mLastVideoTime=0.000000"
"Video Track Buffer Details":"NumSamples=0 Size=0 Evictable=0 NextGetSampleIndex=4294967295 NextInsertionIndex=-1"
"Video Track Buffered":"ranges=[]"
"Compositor dropped frame(including when element's invisible)":"0"
"MediaDecoder=7f2b10da3600":"channels=2 rate=44100 hasAudio=1 hasVideo=1 mPlayState=LOADING"
"MDSM":"duration=57073000 GetMediaTime=0 GetClock=-1 mMediaSink=7f2b1f5b1940 state=DECODING_FIRSTFRAME mPlayState=1 mSentFirstFrameLoadedEvent=0 IsPlaying=0 mAudioStatus=idle mVideoStatus=waiting mDecodedAudioEndTime=96552 mDecodedVideoEndTime=0 mAudioCompleted=0 mVideoCompleted=0 "
"VideoSink":"IsStarted=0 IsPlaying=0 VideoQueue(finished=0 size=0) mVideoFrameEndTime=0 mHasVideo=0 mVideoSinkEndRequest.Exists()=0 mEndPromiseHolder.IsEmpty()=1"
}
}

Tried with also webrender and GL composting on.

Comment 1 Martin Stransky 2019-03-26 06:22:57 UTC
Can you post me any reference video which fails for you? Also can you try latest Firefox update - 66.0.1? Thanks.

Comment 2 Akarshan Biswas 2019-03-26 10:06:37 UTC
Tried with the 66.0.1. It occurs randomly for some videos. One example being https://twitter.com/firefox/status/1104063210318114823
I don't know what's causing this.

Comment 3 Martin Stransky 2019-03-26 11:10:22 UTC
Can you try firefox-x11 package?

Comment 4 Akarshan Biswas 2019-03-27 06:27:10 UTC
I have tried with both firefox-x11 and MOZ_DISABLE_WAYLAND=1. Doesn't help. It only occurs on some videos.

Comment 5 Martin Stransky 2019-03-27 07:52:28 UTC
Please try mozilla binaries (https://fedoraproject.org/wiki/How_to_debug_Firefox_problems#Testing_Mozilla_binaries)
Also please try to create a new profile (https://fedoraproject.org/wiki/How_to_debug_Firefox_problems#Further_troubleshooting_steps).
Thanks.

Comment 6 Akarshan Biswas 2019-03-27 10:56:46 UTC
I used the upstream tarball and launched it on fresh profile. Issue persisted.

However on a different website the video played for a brief moment and then the player crashed and I was able to get the error message.

"NS_ERROR_DOM_MEDIA_DECODE_ERR (0x806e0004) - virtual mozilla::MediaResult mozilla::FFmpegAudioDecoder<58>::DoDecode(mozilla::MediaRawData *, uint8_t *, int, bool *, mozilla::MediaDataDecoder::DecodedData &): FFmpeg audio error:-1313558101"

Comment 7 Martin Stransky 2019-03-27 20:07:55 UTC
Interesting. If that's caused by ffmpeg video backend, it may be reproduced locally. Please try to download the affected video (by youtube-dl for instance) and then play by ffplay utility from command line - can you see similar issues? And are you able to identify the problematic video so I can try to reproduce that? Thanks.

Comment 8 Akarshan Biswas 2019-03-31 06:05:37 UTC
@Martin Unfortunately youtube-dl doesn't support that website. But somehow I have downloaded the video. Played in ffplay and it played well without any issues. Unfortunately I am unable to identify the problematic video. But I know from the error that something is wrong with ffmpegaudiodecoder and Firefox.
The issue being random makes it more difficult to identify the real issue.

Comment 9 Martin Stransky 2019-04-01 11:03:37 UTC
There are reports that the upcoming 66.0.2 may fix that - see bug 1691831.

Comment 10 Akarshan Biswas 2019-04-02 10:08:13 UTC
Update: It appears to have fixed in 66.0.2 so far but I didn't test it on bluejeans. I will add a karma to the update once I test it with bluejeans. Thnx.


Note You need to log in before you can comment on or make changes to this bug.