Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1692624 - Enabling power management in UI throws exceptions
Summary: Enabling power management in UI throws exceptions
Keywords:
Status: CLOSED DUPLICATE of bug 1691398
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.3.0
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ovirt-4.3.4
: ---
Assignee: Gobinda Das
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks: 1692627
TreeView+ depends on / blocked
 
Reported: 2019-03-26 03:54 UTC by bipin
Modified: 2019-03-29 13:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1692627 (view as bug list)
Environment:
Last Closed: 2019-03-29 13:07:00 UTC
oVirt Team: Infra
pm-rhel: ovirt-4.3+


Attachments (Terms of Use)

Description bipin 2019-03-26 03:54:01 UTC
Description of problem:
======================
While enabling the Power management for fencing policies in RHHI-V, could see the fence agent not getting added for any of the hosts. This was seen only while deploying additional hosts using the FQDN tab in cockpit UI.


Version-Release number of selected component
============================================
ovirt-engine-4.3.2.1-0.1.el7.noarch
cockpit-ovirt-dashboard-0.12.5-1.el7ev.noarch
rhvh-4.3.0.5-0.20190313.0+1


How reproducible:
================
Every time

Steps to Reproduce:
==================
1.Proceed with RHHI-V deployment using the additional FQDN tab
2.Once the HE is running, try to enable the Power management 
3.Fill the required tab for agent fence and press the test button


Actual results:
==============
The test takes forever and the fence agent is not added

Expected results:
================
The test should succeed and the agent should be added to enable Power Management


Additional info:
===============
Please change the component if not accurate

Comment 1 bipin 2019-03-26 03:56:20 UTC
2019-03-26 09:05:20,183+05 ERROR [org.ovirt.engine.core.bll.GetAgentFenceOptionsQuery] (default task-233) [1b6f0fdf-ae26-4494-b308-84aa3c9e5529] Query 'GetAgentFenceOptionsQuery' failed: VdsFenceOptionMapping has no value for version: general
2019-03-26 09:05:20,183+05 ERROR [org.ovirt.engine.core.bll.GetAgentFenceOptionsQuery] (default task-233) [1b6f0fdf-ae26-4494-b308-84aa3c9e5529] Exception: java.lang.IllegalArgumentException: VdsFenceOptionMapping has no value for version: general
        at org.ovirt.engine.core.dal.dbbroker.generic.DBConfigUtils.getValue(DBConfigUtils.java:161) [dal.jar:]
        at org.ovirt.engine.core.common.config.Config.getValue(Config.java:28) [common.jar:]
        at org.ovirt.engine.core.utils.pm.FenceConfigHelper.getFenceConfigurationValue(FenceConfigHelper.java:96) [utils.jar:]
        at org.ovirt.engine.core.utils.pm.VdsFenceOptions.cacheFenceAgentsOptionMapping(VdsFenceOptions.java:79) [utils.jar:]
        at org.ovirt.engine.core.utils.pm.VdsFenceOptions.initCache(VdsFenceOptions.java:236) [utils.jar:]
        at org.ovirt.engine.core.utils.pm.VdsFenceOptions.<init>(VdsFenceOptions.java:64) [utils.jar:]
        at org.ovirt.engine.core.utils.pm.VdsFenceOptions.<init>(VdsFenceOptions.java:48) [utils.jar:]
        at org.ovirt.engine.core.bll.GetAgentFenceOptionsQuery.executeQueryCommand(GetAgentFenceOptionsQuery.java:18) [bll.jar:]
        at org.ovirt.engine.core.bll.QueriesCommandBase.executeCommand(QueriesCommandBase.java:106) [bll.jar:]
        at org.ovirt.engine.core.dal.VdcCommandBase.execute(VdcCommandBase.java:31) [dal.jar:]
        at org.ovirt.engine.core.bll.executor.DefaultBackendQueryExecutor.execute(DefaultBackendQueryExecutor.java:14) [bll.jar:]
        at org.ovirt.engine.core.bll.Backend.runQueryImpl(Backend.java:520) [bll.jar:]
        at org.ovirt.engine.core.bll.Backend.runQuery(Backend.java:489) [bll.jar:]
        at sun.reflect.GeneratedMethodAccessor166.invoke(Unknown Source) [:1.8.0_201]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_201]
        at java.lang.reflect.Method.invoke(Method.java:498) [rt.jar:1.8.0_201]
        at org.jboss.as.ee.component.ManagedReferenceMethodInterceptor.processInvocation(ManagedReferenceMethodInterceptor.java:52)
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:422)
        at org.jboss.invocation.InterceptorContext$Invocation.proceed(InterceptorContext.java:509)
        at org.jboss.as.weld.ejb.DelegatingInterceptorInvocationContext.proceed(DelegatingInterceptorInvocationContext.java:92) [wildfly-weld-ejb-7.2.0.GA-redhat-00005.jar:7.2.0.GA-redhat-00005]
        at org.jboss.weld.interceptor.proxy.WeldInvocationContextImpl.interceptorChainCompleted(WeldInvocationContextImpl.java:107) [weld-core-impl.jar:3.0.5.Final-redhat-00001]
        at org.jboss.weld.interceptor.proxy.WeldInvocationContextImpl.proceed(WeldInvocationContextImpl.java:126) [weld-core-impl.jar:3.0.5.Final-redhat-00001]
        at org.ovirt.engine.core.common.di.interceptor.LoggingInterceptor.apply(LoggingInterceptor.java:12) [common.jar:]
        at sun.reflect.GeneratedMethodAccessor61.invoke(Unknown Source) [:1.8.0_201]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_201]
        at java.lang.reflect.Method.invoke(Method.java:498) [rt.jar:1.8.0_201]
        at org.jboss.weld.interceptor.reader.SimpleInterceptorInvocation$SimpleMethodInvocation.invoke(SimpleInterceptorInvocation.java:73) [weld-core-impl.jar:3.0.5.Final-redhat-00001]
        at org.jboss.weld.interceptor.proxy.WeldInvocationContextImpl.invokeNext(WeldInvocationContextImpl.java:92) [weld-core-impl.jar:3.0.5.Final-redhat-00001]
        at org.ovirt.engine.core.common.di.interceptor.LoggingInterceptor.apply(LoggingInterceptor.java:12) [common.jar:]
        at sun.reflect.GeneratedMethodAccessor61.invoke(Unknown Source) [:1.8.0_201]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_201]
        at java.lang.reflect.Method.invoke(Method.java:498) [rt.jar:1.8.0_201]
        at org.jboss.weld.interceptor.reader.SimpleInterceptorInvocation$SimpleMethodInvocation.invoke(SimpleInterceptorInvocation.java:73) [weld-core-impl.jar:3.0.5.Final-redhat-00001]
        at org.jboss.weld.interceptor.proxy.WeldInvocationContextImpl.invokeNext(WeldInvocationContextImpl.java:92) [weld-core-impl.jar:3.0.5.Final-redhat-00001]
        at org.jboss.weld.interceptor.proxy.WeldInvocationContextImpl.proceed(WeldInvocationContextImpl.java:124) [weld-core-impl.jar:3.0.5.Final-redhat-00001]
        at org.jboss.weld.bean.InterceptorImpl.intercept(InterceptorImpl.java:105) [weld-core-impl.jar:3.0.5.Final-redhat-00001]
        at org.jboss.as.weld.ejb.DelegatingInterceptorInvocationContext.proceed(DelegatingInterceptorInvocationContext.java:82) [wildfly-weld-ejb-7.2.0.GA-redhat-00005.jar:7.2.0.GA-redhat-00005]
        at org.jboss.as.weld.interceptors.EjbComponentInterceptorSupport.delegateInterception(EjbComponentInterceptorSupport.java:60)
        at org.jboss.as.weld.interceptors.Jsr299BindingsInterceptor.delegateInterception(Jsr299BindingsInterceptor.java:76)
        at org.jboss.as.weld.interceptors.Jsr299BindingsInterceptor.doMethodInterception(Jsr299BindingsInterceptor.java:88)
        at org.jboss.as.weld.interceptors.Jsr299BindingsInterceptor.processInvocation(Jsr299BindingsInterceptor.java:101)
        at org.jboss.as.ee.component.interceptors.UserInterceptorFactory$1.processInvocation(UserInterceptorFactory.java:63)
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:422)
        at org.jboss.invocation.InterceptorContext$Invocation.proceed(InterceptorContext.java:509)
        at org.ovirt.engine.core.bll.interceptors.CorrelationIdTrackerInterceptor.aroundInvoke(CorrelationIdTrackerInterceptor.java:13) [bll.jar:]
        at sun.reflect.GeneratedMethodAccessor62.invoke(Unknown Source) [:1.8.0_201]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_201]
        at java.lang.reflect.Method.invoke(Method.java:498) [rt.jar:1.8.0_201]
        at org.jboss.as.ee.component.ManagedReferenceLifecycleMethodInterceptor.processInvocation(ManagedReferenceLifecycleMethodInterceptor.java:89)
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:422)
        at org.jboss.as.ejb3.component.invocationmetrics.ExecutionTimeInterceptor.processInvocation(ExecutionTimeInterceptor.java:43) [wildfly-ejb3-7.2.0.GA-redhat-00005.jar:7.2.0.GA-redhat-00005]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:422)
        at org.jboss.as.ee.concurrent.ConcurrentContextInterceptor.processInvocation(ConcurrentContextInterceptor.java:45) [wildfly-ee-7.2.0.GA-redhat-00005.jar:7.2.0.GA-redhat-00005]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:422)
        at org.jboss.invocation.InitialInterceptor.processInvocation(InitialInterceptor.java:40)
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:422)
        at org.jboss.invocation.ChainedInterceptor.processInvocation(ChainedInterceptor.java:53)
        at org.jboss.as.ee.component.interceptors.ComponentDispatcherInterceptor.processInvocation(ComponentDispatcherInterceptor.java:52)
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:422)
        at org.jboss.as.ejb3.component.singleton.SingletonComponentInstanceAssociationInterceptor.processInvocation(SingletonComponentInstanceAssociationInterceptor.java:53) [wildfly-ejb3-7.2.0.GA-redhat-00005.jar:7.2.0.GA-redhat-00005]

Comment 2 bipin 2019-03-26 04:00:22 UTC
UI log
======
2019-03-19 13:14:26,192+05 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-1) [] Permutation name: 5A88572D04238FEB7AD5812B8E9161F6
2019-03-19 13:14:26,192+05 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-1) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) : c is null
        at java.lang.Throwable.Throwable(Throwable.java:70) [rt.jar:1.8.0_201]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_201]
        at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:64) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.fireEvent(Widget.java:127) [gwt-servlet.jar:]
        at com.google.gwt.event.dom.client.DomEvent.fireNativeEvent(DomEvent.java:110) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.$onBrowserEvent(Widget.java:163) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.onBrowserEvent(Widget.java:163) [gwt-servlet.jar:]
        at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1415) [gwt-servlet.jar:]
        at com.google.gwt.user.client.impl.DOMImplStandard.dispatchEvent(DOMImplStandard.java:312) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:236) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:275) [gwt-servlet.jar:]
        at Unknown.Su/<(https://hostedenginesm3.lab.eng.blr.redhat.com/ovirt-engine/webadmin/?locale=en_US)
        at Unknown.anonymous(Unknown)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) : c is null
        at org.ovirt.engine.ui.uicommonweb.models.hosts.FenceAgentModel.$test(FenceAgentModel.java:272)
        at org.ovirt.engine.ui.uicommonweb.models.hosts.FenceAgentModel$1.executeCommand(FenceAgentModel.java:101)
        at org.ovirt.engine.ui.uicommonweb.UICommand.$execute(UICommand.java:163)
        at org.ovirt.engine.ui.webadmin.section.main.presenter.popup.host.HostFenceAgentPopupPresenterWidget.$lambda$1(HostFenceAgentPopupPresenterWidget.java:48)

Comment 4 Ravi Nori 2019-03-29 13:07:00 UTC

*** This bug has been marked as a duplicate of bug 1691398 ***


Note You need to log in before you can comment on or make changes to this bug.