Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1692460 - Let the user specify the host address also deploying from CLI
Summary: Let the user specify the host address also deploying from CLI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Network
Version: 2.3.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.3.3
: ---
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-25 16:23 UTC by Simone Tiraboschi
Modified: 2019-04-16 13:58 UTC (History)
2 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.3.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-16 13:58:11 UTC
oVirt Team: Integration
sbonazzo: ovirt-4.3?
sbonazzo: planning_ack?
sbonazzo: devel_ack+
sbonazzo: testing_ack?


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 98805 ovirt-hosted-engine-setup-2.3 MERGED network: let the user interactively validate host address 2019-03-25 16:29:07 UTC
oVirt gerrit 98869 ovirt-hosted-engine-setup-2.3 MERGED network: let the user interactively validate host address 2019-03-25 16:46:05 UTC

Description Simone Tiraboschi 2019-03-25 16:23:32 UTC
Description of problem:
The host address used to add the host to the engine should resolve on the interface choose for the management bridge in order to correctly apply VLAN setting at engine eyes and so on.
ovirt-ansible-hosted-engine setup role is correctly checking and enforcing this but, deploying from CLI, the user cannot really edit the address that it's going to be used as deploying from cockpit or directly using the role.

On correctly configured environment this is fine but it can generate a bit of ambiguity where the FQDN resolves over a different interface and the user wants to use a different address (that resolves on the interface choose for the management network).

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. deploy from CLI trying to edit the address used to add the host to the engine
2.
3.

Actual results:
deploying for CLI it always try the FQDN

Expected results:
it should let the user review and eventually customize that value

Additional info:
Deploying from cockpit or directly from the role customizing that value is already possible.

Comment 1 Yedidyah Bar David 2019-03-28 08:35:10 UTC
This is a duplicate of bug 1188675. Now fixed, after 4 years :-) Better late than never :-))

Comment 2 Simone Tiraboschi 2019-03-28 09:07:40 UTC
I think that we have fixed and reopened it more then once in the meantime.

Comment 3 Nikolai Sednev 2019-04-02 14:34:16 UTC
[ INFO  ] Stage: Setup validation
          Please provide the hostname of this host on the management network [alma03.qa.lab.tlv.redhat.com]: alma03.qa.lab.tlv.redhat.com

Its now possible to edit FQDN of ha-host via CLI.
Works for me on these components:
ovirt-hosted-engine-setup-2.3.7-1.el7ev.noarch
ovirt-hosted-engine-ha-2.3.1-1.el7ev.noarch
rhvm-appliance-4.3-20190328.1.el7.x86_64
Linux 3.10.0-957.10.1.el7.x86_64 #1 SMP Thu Feb 7 07:12:53 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.6 (Maipo)

Tested on RHEL host.

Moving to verified.

Comment 4 Sandro Bonazzola 2019-04-16 13:58:11 UTC
This bugzilla is included in oVirt 4.3.3 release, published on April 16th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.