Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1692335 - kernel 5.0.3 install causes segmentation fault in dracut
Summary: kernel 5.0.3 install causes segmentation fault in dracut
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-25 11:57 UTC by Leszek Matok
Modified: 2019-03-27 19:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Leszek Matok 2019-03-25 11:57:49 UTC
Description of problem:
When updating F29 to kernel 5.0.3 I got segmentation fault from dracut. This didn't happen with 4.20.6 or any older kernel.


Version-Release number of selected component (if applicable):
dracut-049-25.git20181204.fc29.x86_64
(only in combination with kernel-core-5.0.3-200.fc29.x86_64)


How reproducible:
Tried this once and it failed once ;)


Steps to Reproduce:
1. yum update
2. observe
3.


Actual results:
  Wykonywanie skryptu            : kernel-core-5.0.3-200.fc29.x86_64      51/51 
/usr/lib/dracut/dracut-init.sh: line 969:  8007 Segmentation fault      (core dumped) $DRACUT_INSTALL ${initdir:+-D "$initdir"} ${loginstall:+-L "$loginstall"} ${hostonly:+-H} ${omit_drivers:+-N "$omit_drivers"} ${srcmods:+--kerneldir "$srcmods"} ${_optional:+-o} ${_silent:+--silent} -m "$@"
dracut: FAILED:  /usr/lib/dracut/dracut-install -D /var/tmp/dracut.TsrJ1H/initramfs -H -N nvidia|nvidia_drm|nvidia-modeset|nvidia-uvm --kerneldir /lib/modules/5.0.3-200.fc29.x86_64/ -o -m =drivers/net/phy =drivers/net/team =drivers/net/ethernet ecb arc4 bridge stp llc ipv6 bonding 8021q ipvlan macvlan af_packet virtio_net xennet


dmesg shows:
[12803.646330] dracut-install[8007]: segfault at 0 ip 0000563a8b1c1444 sp 00007ffc8fa173d8 error 4 in dracut-install[563a8b1bb000+a000]
[12803.646333] Code: f2 9d 00 00 48 89 1d eb 9d 00 00 48 89 03 5b c3 66 0f 1f 44 00 00 48 89 df 5b e9 67 a2 ff ff 0f 1f 80 00 00 00 00 f3 0f 1e fa <0f> be 17 b8 05 15 00 00 84 d2 74 18 89 c1 48 83 c7 01 c1 e1 05 01

coredumpctl debug shows:
                Stack trace of thread 8007:
                #0  0x0000563a8b1c1444 n/a (dracut-install)
                #1  0x0000563a8b1c187a n/a (dracut-install)
                #2  0x0000563a8b1bd829 n/a (dracut-install)
                #3  0x0000563a8b1bf7cf n/a (dracut-install)
                #4  0x0000563a8b1bfe6b n/a (dracut-install)
                #5  0x0000563a8b1c0874 n/a (dracut-install)
                #6  0x0000563a8b1bc79d n/a (dracut-install)
                #7  0x00007f9a7a45e413 __libc_start_main (libc.so.6)
                #8  0x0000563a8b1bca7e n/a (dracut-install)

Coredump entry has no core attached (neither internally in the journal nor externally on disk).


Expected results:
Successful post-install scriplet run?

Additional info:

Comment 1 Leszek Matok 2019-03-25 12:05:14 UTC
Actually I found https://bodhi.fedoraproject.org/updates/FEDORA-2019-d6d9903b88 which redirected to bug 1690980 which says it's a duplicate of bug 1685932 which looks like a duplicate of bug 1676357 which says this has been fixed upstream and built in rawhide over a month ago :/

Comment 2 Michal Jaegermann 2019-03-25 16:28:40 UTC
I got the same segfault on two out of three different machines with Fedora 29 when I run these updates.  Luckily enough dracut did produce initramfs-5.0.3-200.fc29.x86_64.img and boot menu entries in all cases.  Results were even bootable.

A rough comparison of produced images with corresponding ones for 4.20.16-200.fc29 shows that where segfault happend assorted firmware files
and network modules were missing.  Not necessarily the same modules in both cases with segfaults.

Comment 3 Berend De Schouwer 2019-03-26 03:56:04 UTC
I got this.  I tried re-installing the rpm, and the same segfault happens.  initramfs is created.

Different hardware means a slightly different command (no nvidia):

/usr/lib/dracut/dracut-init.sh: line 969: 32666 Segmentation fault      (core dumped) $DRACUT_INSTALL ${initdir:+-D "$initdir"} ${loginstall:+-L "$loginstall"} ${hostonly:+-H} ${omit_drivers:+-N "$omit_drivers"} ${srcmods:+--kerneldir "$srcmods"} ${_optional:+-o} ${_silent:+--silent} -m "$@"
dracut: FAILED:  /usr/lib/dracut/dracut-install -D /var/tmp/dracut.okUqOH/initramfs -H --kerneldir /lib/modules/5.0.3-200.fc29.x86_64/ -o -m =drivers/net/phy =drivers/net/team =drivers/net/ethernet ecb arc4 bridge stp llc ipv6 bonding 8021q ipvlan macvlan af_packet virtio_net xennet


Note You need to log in before you can comment on or make changes to this bug.