Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1692332 - virt-v2v: Import from VMware and Xen failed with NPE.
Summary: virt-v2v: Import from VMware and Xen failed with NPE.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: future
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: ovirt-4.3.3
: ---
Assignee: Shmuel Melamud
QA Contact: Nisim Simsolo
URL:
Whiteboard:
: 1692341 1692374 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-25 11:45 UTC by Nisim Simsolo
Modified: 2019-04-16 13:58 UTC (History)
4 users (show)

Fixed In Version: ovirt-engine-4.3.3.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-16 13:58:19 UTC
oVirt Team: Virt
pm-rhel: ovirt-4.3+
pm-rhel: blocker+


Attachments (Terms of Use)
engine.log (deleted)
2019-03-25 11:58 UTC, Nisim Simsolo
no flags Details
vdsm.log (deleted)
2019-03-25 11:58 UTC, Nisim Simsolo
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 98870 master MERGED core: Fixed NPE in ImportVmCommandBase 2019-03-25 19:48:33 UTC
oVirt gerrit 98871 ovirt-engine-4.3 MERGED core: Fixed NPE in ImportVmCommandBase 2019-03-26 08:47:38 UTC
oVirt gerrit 99086 master MERGED core: Fixed NPE on VMWare import 2019-04-01 16:22:25 UTC
oVirt gerrit 99095 ovirt-engine-4.3 MERGED core: Fixed NPE on VMWare import 2019-04-02 08:33:39 UTC

Description Nisim Simsolo 2019-03-25 11:45:54 UTC
Description of problem:
Trying to import from Xen or VMware failed with engine.log NPE:
2019-03-25 13:40:51,954+02 ERROR [org.ovirt.engine.core.bll.exportimport.ImportVmFromExternalProviderCommand] (EE-ManagedThreadFactory-engine-Thread-1593) [25ed0574-6c17-4dd2-a39d-30b2539dffbd] Exception: java.lang.NullPointerException
        at org.ovirt.engine.core.bll.exportimport.ImportVmCommandBase.executeVmCommand(ImportVmCommandBase.java:480) [bll.jar:]
        at org.ovirt.engine.core.bll.VmCommand.executeCommand(VmCommand.java:172) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeWithoutTransaction(CommandBase.java:1157) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeActionInTransactionScope(CommandBase.java:1315) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.runInTransaction(CommandBase.java:1964) [bll.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInSuppressed(TransactionSupport.java:164) [utils.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInScope(TransactionSupport.java:103) [utils.jar:]
        at org.ovirt.engine.core.bll.CommandBase.execute(CommandBase.java:1375) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeAction(CommandBase.java:419) [bll.jar:]
        at org.ovirt.engine.core.bll.PrevalidatingMultipleActionsRunner.executeValidatedCommand(PrevalidatingMultipleActionsRunner.java:204) [bll.jar:]
        at org.ovirt.engine.core.bll.PrevalidatingMultipleActionsRunner.runCommands(PrevalidatingMultipleActionsRunner.java:176) [bll.jar:]
        at org.ovirt.engine.core.bll.PrevalidatingMultipleActionsRunner.lambda$invokeCommands$3(PrevalidatingMultipleActionsRunner.java:182) [bll.jar:]
        at org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil$InternalWrapperRunnable.run(ThreadPoolUtil.java:96) [utils.jar:]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [rt.jar:1.8.0_201]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [rt.jar:1.8.0_201]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [rt.jar:1.8.0_201]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [rt.jar:1.8.0_201]
        at java.lang.Thread.run(Thread.java:748) [rt.jar:1.8.0_201]
        at org.glassfish.enterprise.concurrent.ManagedThreadFactoryImpl$ManagedThread.run(ManagedThreadFactoryImpl.java:250) [javax.enterprise.concurrent-1.0.jar:]
        at org.jboss.as.ee.concurrent.service.ElytronManagedThreadFactory$ElytronManagedThread.run(ElytronManagedThreadFactory.java:78)


Version-Release number of selected component (if applicable):
ovirt-engine-4.4.0-0.0.master.20190323132107.git181b8fe.el7
libvirt-client-4.5.0-10.el7_6.6.x86_64
qemu-kvm-ev-2.12.0-18.el7_6.3.1.x86_64
vdsm-4.40.0-114.git8e34445.el7.x86_64
virt-v2v-1.38.2-12.el7_6.2.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Try to import VM from Xen or VMware
2.
3.

Actual results:
Import failed.

Expected results:


Additional info:
engine.log and vdsm.log attached

Comment 1 Nisim Simsolo 2019-03-25 11:58:34 UTC
Created attachment 1547678 [details]
engine.log

Comment 2 Nisim Simsolo 2019-03-25 11:58:56 UTC
Created attachment 1547679 [details]
vdsm.log

Comment 3 Michal Skrivanek 2019-03-25 14:15:09 UTC
same code made it into 4.3, needs to be fixed in time

Comment 4 Michal Skrivanek 2019-03-25 14:17:57 UTC
regression from Benny's https://gerrit.ovirt.org/#/c/98690
since in this flow we import a "foreign" VM there's no update required when the entity doesn't exist, a simple null check should be enough.

Comment 5 Ryan Barry 2019-03-27 11:58:45 UTC
*** Bug 1692341 has been marked as a duplicate of this bug. ***

Comment 6 Ryan Barry 2019-03-27 11:59:06 UTC
*** Bug 1692374 has been marked as a duplicate of this bug. ***

Comment 7 Nisim Simsolo 2019-04-01 08:41:07 UTC
Reassigned,
Trying to virt-v2v import, failed with the same NPE.

Verification builds:
ovirt-engine-4.4.0-0.0.master.20190331184731.git44f6f4f.el7
vdsm-4.40.0-132.git1a56457.el7.x86_64
libvirt-client-4.5.0-10.el7_6.6.x86_64
qemu-kvm-ev-2.12.0-18.el7_6.3.1.x86_64
sanlock-3.6.0-1.el7.x86_64
virt-v2v-1.38.2-12.el7_6.2.x86_64

Comment 8 Nisim Simsolo 2019-04-03 08:20:59 UTC
verified_upstream:
ovirt-engine-4.4.0-0.0.master.20190401162605.git4822282.el7
vdsm-4.40.0-138.git00b6143.el7.x86_64
libvirt-client-4.5.0-10.el7_6.6.x86_64
qemu-kvm-ev-2.12.0-18.el7_6.3.1.x86_64
sanlock-3.6.0-1.el7.x86_64
virt-v2v-1.38.2-12.el7_6.2.x86_64

Verification scenarios:
1. Import from VMware
2. Import from Xen
3. Import from KVM
4. Import OVA file.

Comment 9 Raz Tamir 2019-04-04 21:30:07 UTC
QE verification bot: the bug was verified upstream

Comment 10 Sandro Bonazzola 2019-04-16 13:58:19 UTC
This bugzilla is included in oVirt 4.3.3 release, published on April 16th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.