Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1692321 - CPU usage reporting overstates utilization
Summary: CPU usage reporting overstates utilization
Keywords:
Status: CLOSED DUPLICATE of bug 1691603
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Frederic Branczyk
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-25 10:56 UTC by Daniel Messer
Modified: 2019-03-25 14:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 14:27:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of CPU meters of example pod (deleted)
2019-03-25 10:56 UTC, Daniel Messer
no flags Details

Description Daniel Messer 2019-03-25 10:56:36 UTC
Created attachment 1547664 [details]
Screenshot of CPU meters of example pod

Description of problem:

Looking at the CPU utilization of Pods the values look overly high. Screenshot is attached. The values displayed are higher than the amount of CPUs available in total to my worker nodes.

Version-Release number of selected component (if applicable):

OpenShift 4 Beta Drop 2:

oc adm release info
Name:      4.0.0-0.7
Digest:    sha256:641c0e4f550af59ec20349187a31751ae5108270f13332d1771935520ebf34c1
Created:   2019-03-05 19:33:12 +0100 CET
OS/Arch:   linux/amd64
Manifests: 248

Release Metadata:
  Version:  4.0.0-0.7
  Upgrades: 4.0.0-0.6
  Metadata:
    description: Beta 2

Component Versions:
  Kubernetes 1.12.4


How reproducible:

Always, deploy any workload in Pods on OCP 4.


Actual results:

Prometheus metrics pod_name:container_cpu_usage:sum is multiplied by 1000.


Expected results:

Prometheus metrics pod_name:container_cpu_usage:sum is not multiplied by 1000 in displayed in milliCPUs.


Additional info:

Comment 1 Matthias Loibl 2019-03-25 14:25:09 UTC
It seems like this was fixed a few days ago: https://github.com/openshift/console/pull/1323

These should be duplicates of this ticket:
https://bugzilla.redhat.com/show_bug.cgi?id=1633127
https://bugzilla.redhat.com/show_bug.cgi?id=1691603

Comment 2 lserven 2019-03-25 14:27:44 UTC

*** This bug has been marked as a duplicate of bug 1691603 ***


Note You need to log in before you can comment on or make changes to this bug.