Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1692294 - default /etc/opensc-x86.conf breaks smartcard readers
Summary: default /etc/opensc-x86.conf breaks smartcard readers
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: opensc
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-25 09:42 UTC by Juha Tuomala
Modified: 2019-03-25 12:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 11:56:08 UTC


Attachments (Terms of Use)

Description Juha Tuomala 2019-03-25 09:42:32 UTC
Description of problem:
System has few USB-connected smartcard readers. They have worked fine in different versions of Fedora since f20, 2014.


Version-Release number of selected component (if applicable):
opensc-0.19.0-5.fc30.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. install/upgrade to f30
2. connect USB-readers
3. opensc-tool -l

Actual results:
opensc-tool -l
No smart card readers found.

Expected results:
Two Gemalto readers listed.


Additional info:
Configuration file is only a stub for some reason:

app default {
        # debug = 3;
        # debug_file = opensc-debug.txt;
        framework pkcs15 {
                # use_file_caching = true;
        }
        reader_driver pcsc {
                # The pinpad is disabled by default,
                # because of many broken readers out there
                enable_pinpad = false;
        }
}


Old config, still as .rpmsave is 460 lines long. Most of it looks like possible values that are commented out, but not the config structures that are not, not sure if they affect to the operation.

Comment 1 Jakub Jelen 2019-03-25 10:41:18 UTC
Please, provide some more information what is the reader you are using and whether using the old configuration with new OpeNSC works for you (or the other way round).

There was many changes in OpenSC in 0.19 and without more information, it is impossible to guess what is the issue.

Comment 2 Juha Tuomala 2019-03-25 11:56:08 UTC
(In reply to Jakub Jelen from comment #1)
> Please, provide some more information what is the reader you are using and
> whether using the old configuration with new OpeNSC works for you (or the
> other way round).
> 
> There was many changes in OpenSC in 0.19 and without more information, it is
> impossible to guess what is the issue.

These are two Gemalto USB readers:

# opensc-tool -l
# Detected readers (pcsc)
Nr.  Card  Features  Name
0    Yes             Gemalto PC Twin Reader (6B2A4AC2) 00 00
1    Yes             Gemalto PC Twin Reader (DF244A22) 01 00


I saw some errors at kernel messages:

[80732.622935] usb 2-1.4.1.1: new high-speed USB device number 23 using ehci-pci
[80732.651951] hub 2-1.4.1:1.0: hub_ext_port_status failed (err = -71)
[80732.656237] usb 2-1.4.1-port1: cannot reset (err = -71)
[80732.660445] usb 2-1.4.1-port1: cannot reset (err = -71)
[80732.664694] usb 2-1.4.1-port1: cannot reset (err = -71)
[80732.669109] usb 2-1.4.1-port1: cannot reset (err = -71)
[80732.669110] usb 2-1.4.1-port1: Cannot enable. Maybe the USB cable is bad?
[80732.673483] usb 2-1.4.1-port1: cannot disable (err = -71)
[80732.673488] usb 2-1.4.1-port1: attempt power cycle
[80733.013828] hub 2-1.4.1:1.0: hub_ext_port_status failed (err = -71)
[80733.225368] hub 2-1.4.1:1.0: hub_ext_port_status failed (err = -71)
[80733.229605] usb 2-1.4.1-port1: cannot reset (err = -71)
[80733.441128] hub 2-1.4.1:1.0: hub_ext_port_status failed (err = -71)
[80733.445368] usb 2-1.4.1-port1: cannot reset (err = -71)
[80733.445372] usb 2-1.4.1-port1: Cannot enable. Maybe the USB cable is bad?
[80733.449617] usb 2-1.4.1-port1: cannot disable (err = -71)
[80733.453824] usb 2-1.4.1-port1: cannot reset (err = -71)
[80733.664967] hub 2-1.4.1:1.0: hub_ext_port_status failed (err = -71)
[80733.872848] hub 2-1.4.1:1.0: hub_ext_port_status failed (err = -71)
[80733.877084] usb 2-1.4.1-port1: cannot reset (err = -71)
[80733.881356] usb 2-1.4.1-port1: cannot reset (err = -71)
[80733.881359] usb 2-1.4.1-port1: Cannot enable. Maybe the USB cable is bad?
[80733.881828] usb 2-1.4.1-port1: unable to enumerate USB device


both readers are connected to display's internal hub so that they loose power when display is switched off. Apparently something didn't like that in f30. I moved one reader into desktop machine's chassis connectors and they appear to work now. Not sure why.

Comment 3 Juha Tuomala 2019-03-25 12:05:07 UTC
There's another issue with pkcs#11 that existed already in f29 that I updated a week ago. Reported it to bug #1692337.


Note You need to log in before you can comment on or make changes to this bug.