Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1692254 - Option to "Open RPM in Software Installer" fails to open RPM in Software Installer
Summary: Option to "Open RPM in Software Installer" fails to open RPM in Software Inst...
Keywords:
Status: NEW
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-software
Version: 7.6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Richard Hughes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-25 07:20 UTC by klaatu
Modified: 2019-03-25 07:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)

Description klaatu 2019-03-25 07:20:35 UTC
Description of problem:
In Firefox and Chrome, after downloading an RPM, the RPM fails to open in Software Install (gnome-software).

Version-Release number of selected component (if applicable):
$ gnome-software --version
3.28.2

How reproducible:
100%


Steps to Reproduce:
Firefox:
1. Download an RPM
2. When prompted by Firefox, select 'Open in Software Installer' and click OK.


Chrome:
1. Download an RPM
2. When prompted by Chrome, click 'Keep' 
3. Click on RPM to open it.


Actual results:

Software Installer fails to open or opens with a message "Sorry, something went wrong"

Expected results:
Software installer should open and offer to install the RPM


Note You need to log in before you can comment on or make changes to this bug.