Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1692174 - RHOSP13 Overcloud deployment failed with ceph_base_ansible_workflow
Summary: RHOSP13 Overcloud deployment failed with ceph_base_ansible_workflow
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ceph-ansible
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Guillaume Abrioux
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-24 20:54 UTC by Jorge Salas
Modified: 2019-03-26 09:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-26 09:15:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jorge Salas 2019-03-24 20:54:46 UTC
Description of problem:

Overcloud deployment failed with reason:

overcloud.AllNodesDeploySteps.WorkflowTasks_Step2_Execution:
  resource_type: OS::TripleO::WorkflowSteps
  physical_resource_id: d08240af-d9b0-447c-a389-2837fed166e8
  status: CREATE_FAILED
  status_reason: |
    resources.WorkflowTasks_Step2_Execution: Failure caused by error in tasks: ceph_base_ansible_workflow

      ceph_base_ansible_workflow [task_ex_id=6940215a-73a0-4e0f-80d2-0c4189b271a2] -> Failure caused by error in tasks: ceph_install

Checking Mistral logs:

[root@undercloud mistral]# cat ceph-install-workflow.log
.
.

2019-03-22 08:43:21,803 p=4542 u=mistral |  fatal: [172.16.0.36]: FAILED! => {
    "changed": false,
    "invocation": {
        "module_args": {
            "dest": "/etc/ceph/ceph.conf",
            "follow": true,
            "group": "root",
            "mode": "0644",
            "original_basename": "ceph.conf.j2",
            "owner": "root",
            "src": "/home/tripleo-admin/.ansible/tmp/ansible-tmp-1553258600.91-269033794722952/source"
        }
    },
    "msg": "Unsupported parameters for (copy) module: original_basename Supported parameters include: _original_basename, attributes, backup, checksum, content, delimiter, dest, directory_mode, follow, force, group, local_follow, mode, owner, regexp, remote_src, selevel, serole, setype, seuser, src, unsafe_writes, validate"
}


Version-Release number of selected component (if applicable):

RHOSP13
(undercloud) [stack@undercloud ~]$ rpm -qa |grep ceph-ansible
ceph-ansible-3.1.5-1.el7cp.noarch

[root@undercloud mistral]# ansible --version
ansible 2.6.11


How reproducible:

Overcloud deployment using virsh networks and using the ceph-ansible configuration in /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-ansible.yaml 

Steps to Reproduce:
1. Install undercloud in a virsh VM
2. Deploy overcloud with ceph node using the default ansible configuration file in a virsh VM

Actual results:

Overcloud deployment fails with resources.WorkflowTasks_Step2_Execution: Failure caused by error in tasks: ceph_base_ansible_workflow

Expected results:

Ceph configuration finish with no errors.

Additional info: N.A

Comment 2 Jorge Salas 2019-03-26 09:15:44 UTC
Solved by using ceph-ansible 3.2 as indicated here [1]

Once installed RHCS 3.2 repo, ansible is updated to 3.2 version and it works.

[1] https://access.redhat.com/solutions/3954041.


Note You need to log in before you can comment on or make changes to this bug.