Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1692121 - Remove rhv-guest-tools-iso requirement
Summary: Remove rhv-guest-tools-iso requirement
Keywords:
Status: CLOSED DUPLICATE of bug 1588498
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Gal Zaidman
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-24 13:08 UTC by Gal Zaidman
Modified: 2019-03-25 10:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 10:27:12 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)

Description Gal Zaidman 2019-03-24 13:08:43 UTC
Description of problem:
Until 4.1, the rhv-tools-setup.iso image was automatically uploaded to the NFS ISO domain, by engine-setup, if such a domain was created by it.

Creation of an NFS ISO domain by engine-setup on the engine machine is risky and deprecated, see bug 1332813. In 4.2, engine-setup does not query about this anymore, and also in 4.1 it defaulted to not create one.

Because we removed that behavior and rhv-tools-setup.iso need to be uploaded manually to the iso domain, we can remove the requirement of rhv-guest-tools-iso package and if someone will want to have a win VM, he will have to install the rhv-guest-tools-iso package (will require to fix the docs accordingly) and continue from there as we do now.

notice that rhv-guest-tools-iso is a very big package.

Comment 1 Michal Skrivanek 2019-03-25 05:25:56 UTC
Why do you want to make it even more complicated?

Comment 2 Gal Zaidman 2019-03-25 10:27:12 UTC
We can close this since its already been done :)

*** This bug has been marked as a duplicate of bug 1588498 ***


Note You need to log in before you can comment on or make changes to this bug.