Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1691699 - resource agents src.rpm requires unavailable python2-devel and perl-generators
Summary: resource agents src.rpm requires unavailable python2-devel and perl-generators
Keywords:
Status: CLOSED DUPLICATE of bug 1595854
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: resource-agents
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Oyvind Albrigtsen
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-22 09:47 UTC by michal novacek
Modified: 2019-03-22 09:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-22 09:52:31 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description michal novacek 2019-03-22 09:47:38 UTC
>+ yum-builddep -y /tps/src/resource-agents-4.1.1-17.el8.src.rpm
Updating Subscription Management repositories.
Unable to read consumer identity
Subscription Manager is operating in container mode.
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Updating Subscription Management repositories.
Unable to read consumer identity
Subscription Manager is operating in container mode.
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Last metadata expiration check: 0:00:15 ago on Fri Mar 22 06:55:30 2019.
Package systemd-239-8.el8.x86_64 is already installed.
Package which-2.21-10.el8.x86_64 is already installed.
Error:
 Problem 1: conflicting requests
  - package python2-devel-2.7.15-16.el8.x86_64 is excluded
 Problem 2: cannot install the best candidate for the job
  - package perl-generators-1.10-7.module+el8+2464+d274aed1.noarch is excluded
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
++ exit 1

For "python-devel" it should probably be replaced with "platform-python-devel". No idea about "perl-generators".

Comment 1 Oyvind Albrigtsen 2019-03-22 09:52:31 UTC

*** This bug has been marked as a duplicate of bug 1595854 ***


Note You need to log in before you can comment on or make changes to this bug.