Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1691600 - false failure in kube-scheduler operator update
Summary: false failure in kube-scheduler operator update
Keywords:
Status: CLOSED DUPLICATE of bug 1690153
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Seth Jennings
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-22 02:43 UTC by Ryan Cook
Modified: 2019-03-26 03:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-26 03:14:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ryan Cook 2019-03-22 02:43:26 UTC
Description of problem: Preformed full OpenShift update using console from .6 -> .7 but only one update failed kube-scheduler


Version-Release number of selected component (if applicable):


How reproducible: Deploy new cluster of .6 and then patch to .7


Steps to Reproduce:
1. login to the console
2. administration -> cluster settings
3. click update

Actual results:

kube-scheduler states failed NodeInstallerFailing: 0 nodes are failing on revision 1: NodeInstallerFailing:

Expected results: Not failed


Additional info:
8m        8m        1         openshift-kube-scheduler-operator.158e26fc7230b9bf   Deployment             Normal    SecretUpdated               openshift-cluster-kube-scheduler-operator   Updated Secret/kube-scheduler-client-cert-key-1 -n openshift-kube-scheduler because it changed
8m        8m        1         openshift-kube-scheduler-operator.158e26fc73295884   Deployment             Normal    RevisionCreate              openshift-cluster-kube-scheduler-operator   Revision 0 created because configmap "kube-scheduler-pod-0" not found
8m        8m        1         openshift-kube-scheduler-operator.158e26fd5419a05a   Deployment             Normal    ConfigMapUpdated            openshift-cluster-kube-scheduler-operator   Updated ConfigMap/kube-scheduler-pod -n openshift-kube-scheduler: cause by changes in data.pod.yaml
8m        8m        1         openshift-kube-scheduler-operator.158e26fd5466b5a3   Deployment             Normal    RevisionTriggered           openshift-cluster-kube-scheduler-operator   new revision 2 triggered by "configmap/kube-scheduler-pod has changed"
8m        8m        1         openshift-kube-scheduler-operator.158e26fd83ca13ed   Deployment             Normal    ConfigMapUpdated            openshift-cluster-kube-scheduler-operator   Updated ConfigMap/revision-status-2 -n openshift-kube-scheduler: cause by changes in data.status
8m        8m        1         openshift-kube-scheduler-operator.158e26fdb5264808   Deployment             Normal    NodeTargetRevisionChanged   openshift-cluster-kube-scheduler-operator   Updating node "ip-10-0-153-76.ec2.internal" from revision 0 to 1

oc get pods -n openshift-kube-scheduler-operator
NAME                                                 READY     STATUS    RESTARTS   AGE
openshift-kube-scheduler-operator-5f48c796c5-rm9th   1/1       Running   0          13m

Comment 1 Xingxing Xia 2019-03-26 03:14:02 UTC

*** This bug has been marked as a duplicate of bug 1690153 ***


Note You need to log in before you can comment on or make changes to this bug.