Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1691586 - Dell SC cinder driver retype failure: Multiple copies of volume xxxxx found
Summary: Dell SC cinder driver retype failure: Multiple copies of volume xxxxx found
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Pablo Caruana
QA Contact: Tzach Shefi
Tana
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-22 00:45 UTC by Sam Wan
Modified: 2019-03-22 11:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-22 03:32:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
cinder volume log (deleted)
2019-03-22 00:45 UTC, Sam Wan
no flags Details

Description Sam Wan 2019-03-22 00:45:27 UTC
Created attachment 1546733 [details]
cinder volume log

Description of problem:
when running RHOSP14 certifications on Dell SC cinder driver, test cases related to retype/migration failed.

Version-Release number of selected component (if applicable):
RHOSP14

How reproducible:
tempest run --regex test_volume_retype

Steps to Reproduce:
1. configure tempest
2. run test_volume_retype 
3.

Actual results:
failed

Expected results:
pass

Additional info:
error in cinder log
======
2019-03-20 02:46:20.731 381 ERROR cinder.volume.drivers.dell_emc.sc.storagecenter_common [req-687d8013-ae77-4d42-98b6-182592908775 043a15bbffbf47889c8ad14ef97c5c80 8cd918861c13477db46f571316bad7bb - default default] Failed to delete volume b762ff18-8a71-4f0c-ae76-6b98f06baf87: VolumeBackendAPIException: Bad or unexpected response from the storage volume backend API: Multiple copies of volume b762ff18-8a71-4f0c-ae76-6b98f06baf87 found.
2019-03-20 02:46:20.748 381 INFO cinder.volume.manager [req-687d8013-ae77-4d42-98b6-182592908775 043a15bbffbf47889c8ad14ef97c5c80 8cd918861c13477db46f571316bad7bb - default default] Retype volume completed successfully.
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server [req-687d8013-ae77-4d42-98b6-182592908775 043a15bbffbf47889c8ad14ef97c5c80 8cd918861c13477db46f571316bad7bb - default default] Exception during message handling: VolumeBackendAPIException: Bad or unexpected response from the storage volume backend API: Multiple copies of volume b762ff18-8a71-4f0c-ae76-6b98f06baf87 found.
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server Traceback (most recent call last):
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/server.py", line 163, in _process_incoming
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     res = self.dispatcher.dispatch(message)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/dispatcher.py", line 265, in dispatch
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     return self._do_dispatch(endpoint, method, ctxt, args)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/dispatcher.py", line 194, in _do_dispatch
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     result = func(ctxt, **new_args)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "<string>", line 2, in delete_volume
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/cinder/coordination.py", line 151, in _synchronized
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     return f(*a, **k)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "<string>", line 2, in delete_volume
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/cinder/objects/cleanable.py", line 207, in wrapper
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     result = f(*args, **kwargs)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/cinder/volume/manager.py", line 833, in delete_volume
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     new_status)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 220, in __exit__
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     self.force_reraise()
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 196, in force_reraise
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     six.reraise(self.type_, self.value, self.tb)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/cinder/volume/manager.py", line 815, in delete_volume
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     self.driver.delete_volume(volume)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/dell_emc/sc/storagecenter_common.py", line 452, in delete_volume
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     volume_name)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 220, in __exit__
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     self.force_reraise()
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 196, in force_reraise
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     six.reraise(self.type_, self.value, self.tb)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/dell_emc/sc/storagecenter_common.py", line 448, in delete_volume
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     deleted = api.delete_volume(volume_name, provider_id)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/dell_emc/sc/storagecenter_api.py", line 1327, in delete_volume
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     vol = self.find_volume(name, provider_id)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/dell_emc/sc/storagecenter_api.py", line 1262, in find_volume
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     scvolume = self._search_for_volume(name)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/dell_emc/sc/storagecenter_api.py", line 1299, in _search_for_volume
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server     raise exception.VolumeBackendAPIException(data=msg)
2019-03-20 02:46:20.753 381 ERROR oslo_messaging.rpc.server VolumeBackendAPIException: Bad or unexpected response from the storage volume backend API: Multiple copies of volume b762ff18-8a71-4f0c-ae76-6b98f06baf87 found.
======

Comment 1 Sam Wan 2019-03-22 03:32:49 UTC
sorry this is not a bug, it's a configuration error.
when configuring multple backends, they should have different 'dell_sc_volume_folder' otherwise same name would exist in the same folder when retyping/migrating.
eg:
======
[sciscsi1]
volume_backend_name=sciscsi1
volume_driver=cinder.volume.drivers.dell_emc.sc.storagecenter_iscsi.SCISCSIDriver
san_ip=xx.xx.xx.xx
san_login=xxxx
san_password=xxxx
dell_sc_ssn=xxxx
dell_sc_server_folder=openstack_iscsi
dell_sc_volume_folder=cinder1

[sciscsi2]
volume_backend_name=sciscsi2
volume_driver=cinder.volume.drivers.dell_emc.sc.storagecenter_iscsi.SCISCSIDriver
san_ip=xx.xx.xx.xx
san_login=xxxx
san_password=xxxx
dell_sc_ssn=xxxx
dell_sc_server_folder=openstack_iscsi
dell_sc_volume_folder=cinder2
======
closed as not a bug.


Note You need to log in before you can comment on or make changes to this bug.