Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1691523 - rebooted master now SELINUX issue stops from booting
Summary: rebooted master now SELINUX issue stops from booting
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Steve Milner
QA Contact: Micah Abbott
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-21 19:53 UTC by Ryan Cook
Modified: 2019-03-25 21:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 21:34:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ryan Cook 2019-03-21 19:53:21 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ryan Cook 2019-03-21 19:56:37 UTC
Description of problem: rebooted master instance due to some issues within AWS


Version-Release number of selected component (if applicable): unsure


How reproducible: I had patched the masters using the web console issues I was experience so chose to reboot master instance to ensure it wasn't a network issue within AWS


Steps to Reproduce:
1. reboot coreos instance
2. if this does not cause an error patch 
3. reboot coreos instance

Actual results:
Welcome to [0;31mRed Hat CoreOS 4.0[0m!

[[32m  OK  [0m] Stopped Switch Root.
[[32m  OK  [0m] Stopped Journal Service.
         Starting Journal Service...
[[32m  OK  [0m] Set up automount Arbitrary Executab...ats File System Automount Point.
[[32m  OK  [0m] Created slice User and Session Slice.
[[32m  OK  [0m] Reached target Local Encrypted Volumes.
[[32m  OK  [0m] Reached target Remote File Systems.
[[32m  OK  [0m] Reached target Slices.
[[32m  OK  [0m] Created slice system-selinux\x2dpol...grate\x2dlocal\x2dchanges.slice.
[[32m  OK  [0m] Listening on Delayed Shutdown Socket.
[[32m  OK  [0m] Listening on LVM2 poll daemon socket.
[[32m  OK  [0m] Created slice system-getty.slice.
[[32m  OK  [0m] Reached target Host and Network Name Lookups.
         Starting Setup Virtual Console...
[[32m  OK  [0m] Started Dispatch Password Requests to Console Directory Watch.
[[32m  OK  [0m] Created slice system-serial\x2dgetty.slice.
[[32m  OK  [0m] Listening on LVM2 metadata daemon socket.
[[32m  OK  [0m] Started Forward Password Requests to Wall Directory Watch.
         Starting Create list of required st... nodes for the current kernel...
         Starting Apply Kernel Variables...
[[32m  OK  [0m] Listening on Device-mapper event daemon FIFOs.
         Starting Monitoring of LVM2 mirrors... dmeventd or progress polling...
[[32m  OK  [0m] Stopped target Switch Root.
[[32m  OK  [0m] Stopped target Initrd File Systems.
[[32m  OK  [0m] Stopped target Initrd Root File System.
[[32m  OK  [0m] Reached target Remote Encrypted Volumes.
[[32m  OK  [0m] Stopped File System Check on Root Device.
         Mounting Debug File System...
[[32m  OK  [0m] Listening on /dev/initctl Compatibility Named Pipe.
[[32m  OK  [0m] Reached target RPC Port Mapper.
         Starting Remount Root and Kernel File Systems...
         Mounting POSIX Message Queue File System...
[[32m  OK  [0m] Listening on udev Control Socket.
         Mounting Huge Pages File System...
[[32m  OK  [0m] Listening on udev Kernel Socket.
[[32m  OK  [0m] Stopped OSTree Prepare OS/.
         Starting Availability of block devices...
[[32m  OK  [0m] Reached target Swap.
         Mounting Temporary Directory...
[[32m  OK  [0m] Mounted Debug File System.
[[32m  OK  [0m] Mounted POSIX Message Queue File System.
[[32m  OK  [0m] Mounted Huge Pages File System.
[[32m  OK  [0m] Mounted Temporary Directory.
[[32m  OK  [0m] Started Journal Service.
[[32m  OK  [0m] Started Setup Virtual Console.
[[32m  OK  [0m] Started Create list of required sta...ce nodes for the current kernel.
[[32m  OK  [0m] Started Apply Kernel Variables.
[[32m  OK  [0m] Started Remount Root and Kernel File Systems.
[[32m  OK  [0m] Started Availability of block devices.
[[32m  OK  [0m] Started LVM2 metadata daemon.
         Starting OSTree Remount OS/ Bind Mounts...
         Starting udev Coldplug all Devices...
         Starting Create Static Device Nodes in /dev...
[[32m  OK  [0m] Started OSTree Remount OS/ Bind Mounts.
[[32m  OK  [0m] Started Create Static Device Nodes in /dev.
[[32m  OK  [0m] Started udev Coldplug all Devices.
         Starting udev Kernel Device Manager...
[[32m  OK  [0m] Started udev Kernel Device Manager.
[    9.570249] input: PC Speaker as /devices/platform/pcspkr/input/input3
[    9.577457] piix4_smbus 0000:00:01.3: SMBus Host Controller at 0xb100, revision 255
[[32m  OK  [0m] Found device /dev/ttyS0.
[    9.636548] parport_pc 00:03: reported by Plug and Play ACPI
[    9.643533] Error: Driver 'pcspkr' is already registered, aborting...
[[32m  OK  [0m] Found device Amazon Elastic Block Store boot.
[[32m  OK  [0m] Started Monitoring of LVM2 mirrors,...ng dmeventd or progress polling.
[[32m  OK  [0m] Reached target Local File Systems (Pre).
         Mounting /var...
         Mounting /boot...
[    9.740951] XFS (nvme0n1p1): Mounting V5 Filesystem
[[32m  OK  [0m] Mounted /var.
         Starting Flush Journal to Persistent Storage...
         Starting Load/Save Random Seed...
[[32m  OK  [0m] Started Load/Save Random Seed.
[    9.794076] systemd-journald[1845]: Received request to flush runtime journal from PID 1
[    9.893092] ppdev: user-space parallel port driver
[[32m  OK  [0m] Started Flush Journal to Persistent Storage.
[   10.483306] XFS (nvme0n1p1): Ending clean mount
[[32m  OK  [0m] Mounted /boot.
[[32m  OK  [0m] Reached target Local File Systems.
         Starting Create Volatile Files and Directories...
         Starting Preprocess NFS configuration...
[[32m  OK  [0m] Started Preprocess NFS configuration.
[[32m  OK  [0m] Started Create Volatile Files and Directories.
         Starting Update UTMP about System Boot/Shutdown...
[[32m  OK  [0m] Started Update UTMP about System Boot/Shutdown.
[[32m  OK  [0m] Reached target System Initialization.
[[32m  OK  [0m] Listening on RPCbind Server Activation Socket.
         Starting RPC bind service...
[[32m  OK  [0m] Listening on D-Bus System Message Bus Socket.
[[32m  OK  [0m] Reached target Sockets.
[[32m  OK  [0m] Started Daily Cleanup of Temporary Directories.
[[32m  OK  [0m] Reached target Timers.
[[32m  OK  [0m] Started OSTree Monitor Staged Deployment.
[[32m  OK  [0m] Reached target Paths.
[[32m  OK  [0m] Reached target Basic System.
[[32m  OK  [0m] Started irqbalance daemon.
         Starting Log RPM-OSTree Booted Deployment Status To Journal...
[[32m  OK  [0m] Started D-Bus System Message Bus.
         Starting Network Manager...
         Starting NTP client/server...
         Starting Login Service...
         Starting Permit User Sessions...
         Starting Pivot Tool...
[[32m  OK  [0m] Reached target Containers.
[[32m  OK  [0m] Started RPC bind service.
[[32m  OK  [0m] Started Permit User Sessions.
[[32m  OK  [0m] Started Network Manager.
[[32m  OK  [0m] Started Login Service.
[[32m  OK  [0m] Reached target Network.
         Starting OpenSSH server daemon...
         Starting Network Manager Wait Online...
         Starting RPM-OSTree System Management Daemon...
[[32m  OK  [0m] Started Serial Getty on ttyS0.
[[32m  OK  [0m] Started Getty on tty1.
[[32m  OK  [0m] Reached target Login Prompts.
[[32m  OK  [0m] Started OpenSSH server daemon.
[[32m  OK  [0m] Started NTP client/server.
         Starting Authorization Manager...
         Starting Hostname Service...
[[32m  OK  [0m] Started Hostname Service.
         Starting Network Manager Script Dispatcher Service...
[[32m  OK  [0m] Started Network Manager Script Dispatcher Service.
[[32m  OK  [0m] Started Authorization Manager.
[[32m  OK  [0m] Started RPM-OSTree System Management Daemon.
[[32m  OK  [0m] Started Log RPM-OSTree Booted Deployment Status To Journal.
[[32m  OK  [0m] Started Network Manager Wait Online.
[[32m  OK  [0m] Reached target Network is Online.
         Starting NFS status monitor for NFSv2/3 locking....
         Starting Open Container Initiative Daemon...
[[32m  OK  [0m] Started NFS status monitor for NFSv2/3 locking..
[   11.424848] TECH PREVIEW: Overlay filesystem may not be fully supported.
[   11.424848] Please review provided documentation for limitations.
[   11.628036] nf_conntrack version 0.5.0 (65536 buckets, 262144 max)
[   12.166222] random: crng init done
[[32m  OK  [0m] Started Open Container Initiative Daemon.


Red Hat CoreOS 4.0
Kernel 3.10.0-957.5.1.el7.x86_64 on an x86_64

ip-10-1-132-96 login: [  169.448135] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  169.467663] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  169.608698] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  169.623827] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  169.699179] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  169.802781] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  170.040888] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  170.168874] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  170.282444] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  171.318209] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  185.381915] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  185.901416] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  186.707978] openvswitch: Open vSwitch switching datapath
[  186.804884] device ovs-system entered promiscuous mode
[  186.865470] device tun0 entered promiscuous mode
[  186.897713] device vxlan_sys_4789 entered promiscuous mode
[  186.984073] device br0 entered promiscuous mode
[  187.489033] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  187.543279] device br0 left promiscuous mode
[  187.559478] device tun0 left promiscuous mode
[  187.573178] device vxlan_sys_4789 left promiscuous mode
[  187.588001] device ovs-system left promiscuous mode
[  187.609176] device ovs-system entered promiscuous mode
[  187.625185] device br0 entered promiscuous mode
[  187.723110] device vxlan_sys_4789 entered promiscuous mode
[  187.773175] device tun0 entered promiscuous mode
[  189.420862] SELinux: mount invalid.  Same superblock, different security settings for (dev mqueue, type mqueue)
[  189.664308] repeated.....


Expected results: reboot


Additional info:

Comment 3 Ryan Cook 2019-03-21 20:07:34 UTC
machine-os and all other relevant patches. Went from 4.0.0-0.6 to I want to potentially 4.0.0-0.8

Comment 8 Ryan Cook 2019-03-25 13:51:10 UTC
I think this can be closed. Based on the above that the SELINUX warning should be a non-issue so I would say this is a closed based on unable to reproduce. I had a bad OpenShift update and I believe I linked the console messages to the bad update. So I would say let's go ahead and close


Note You need to log in before you can comment on or make changes to this bug.