Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 169121 - Select Generic PostScript model for unknown PS-capable printers
Summary: Select Generic PostScript model for unknown PS-capable printers
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: foomatic
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-09-23 12:24 UTC by Peter Odufona
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-10 15:08:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Peter Odufona 2005-09-23 12:24:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
Description of Problem:

ref: Bug 139218

I have an Oki B4350 printer. system-config-printer produces the following message on startup:

No match for USB device:
mfr "OKI DATA CORP"
model "B4350"
desc "OKI B4350"
cmdset "PJL,PCL,IBMPPR,EPSONFX,POSTSCRIPT,PCLXL"


and also...

No match for USB device:
mfr "Star"
model "TSP 700 (STR_T-U001)"
desc ""
cmdset "STAR"

Thanks


Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-11,  system-config-printer-0.6.116-1

How reproducible:
Didn't try


Additional info:

Comment 1 Tim Waugh 2005-09-23 13:02:38 UTC
I think there should be more lines to the output.  Does the full output for this
one:

No match for USB device:
mfr "OKI DATA CORP"
model "B4350"
desc "OKI B4350"
cmdset "PJL,PCL,IBMPPR,EPSONFX,POSTSCRIPT,PCLXL"

say that it will choose Generic PostScript as the model? (And does it indeed do
that when you go to create a new queue for it?)

(Neither of these printers are listed in the foomatic database.)

Comment 2 Peter Odufona 2005-09-23 13:08:08 UTC
Apologies!

Beneath the "Please report this message to Bugzilla" line for both types of
printer, it reads...

Choose 'foomatic' as the component.

Hope this helps!

Rgds.

Comment 3 Tim Waugh 2005-09-23 13:09:36 UTC
When you go to create a new queue for that printer, is 'Generic PostScript'
selected automatically in the model list?

Comment 4 Peter Odufona 2005-09-23 13:30:47 UTC
No.

At the the printer model selection screen it defaults to :

Generic (click to select manufacturer), but none selected automatically or
highlighted.

queue type = Locally-connected

Comment 5 Tim Waugh 2005-09-23 15:47:03 UTC
Ah, okay, it only does what I expected it to for printers discovered using SNMP.
 It should do that for locally-connected printers as well.

Comment 6 Malcolm 2005-09-26 15:40:03 UTC
Tim, 

let me know who things are going, will be onsite with Specsavers on Wednesday,
as they have a support account, will run an Issue Tracker escalation as well....

Malcolm

Comment 7 Tim Waugh 2005-09-26 16:00:15 UTC
Just to clarify, I'm taking this bug report to be that PostScript-capable
printers are not automatically detected as "Generic PostScript", meaning that
the user has to manually select that.

Fixing this will not enable printing in a situation where printing is not
working.  Specifically, if there is a driver missing (for the Star printer?),
that is a much bigger job to rectify (and not normally something we'd do via
Bugzilla).

We will not make an update available for the Generic PostScript auto-selection
feature, since the easy work-around is to select "Generic PostScript" from the list.

Comment 8 Tim Waugh 2005-11-10 15:08:53 UTC
Fixed in rawhide package system-config-printer-0.6.145-1.  The fix will be
included in a future release of Red Hat Enterprise Linux.


Note You need to log in before you can comment on or make changes to this bug.