Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1691112 - Installation failure
Summary: Installation failure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: zorba
Version: 29
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Martin Gieseking
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 21:45 UTC by Robert Boissy
Modified: 2019-04-02 02:13 UTC (History)
2 users (show)

Fixed In Version: zorba-3.0.0-44.20140621git152f8964c.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-02 02:13:51 UTC


Attachments (Terms of Use)

Description Robert Boissy 2019-03-20 21:45:06 UTC
Description of problem:

zorba-3.0.0-43.20140621git152f8964c.fc29.x86_64 fails to install.

Version-Release number of selected component (if applicable):

3.0.0-43.20140621git152f8964c.fc29.x86_64

How reproducible:

Always 

Steps to Reproduce:
1. Run the following command: 'sudo dnf -y install zorba'
2. Command fails.
3. 

Actual results:

Command fails with the following error:

Error: 
 Problem: conflicting requests
  - nothing provides libutil-curl.so needed by zorba-3.0.0-43.20140621git152f8964c.fc29.i686
  - nothing provides libutil-curl.so()(64bit) needed by zorba-3.0.0-43.20140621git152f8964c.fc29.x86_64
  

Expected results:

Installation of the zorba package without error.

Additional info:

The zorba package itself provides the alleged missing dependency (libutil-curl.so)

repoquery -lq zorba | grep libutil-curl\.so
/usr/lib64/libutil-curl.so
/usr/lib/libutil-curl.so


I can install an earlier version from Koji. This works:

sudo dnf -y install \
https://kojipkgs.fedoraproject.org//packages/zorba/3.0.0/39.20140621git152f8964c.fc29/x86_64/zorba-3.0.0-39.20140621git152f8964c.fc29.x86_64.rpm

Comment 1 Martin Gieseking 2019-03-21 16:36:19 UTC
Unfortunately, the Zorba project seems to be dead and the code is getting increasingly older with every update of its dependencies. Therefore, the zorba package has been retired, i.e. it's no longer available as of F30. I just fixed a couple of build issues that should also resolve the installation problem. The packages are currently being built:
https://koji.fedoraproject.org/koji/taskinfo?taskID=33675584

Fixing the Ruby bindings would need a lot more work which I can't afford at the moment. That's why I dropped the zorba-ruby subpackage.

Comment 2 Fedora Update System 2019-03-21 21:28:54 UTC
zorba-3.0.0-44.20140621git152f8964c.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-8ad350f067

Comment 3 Fedora Update System 2019-03-23 02:41:12 UTC
zorba-3.0.0-44.20140621git152f8964c.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-8ad350f067

Comment 4 Fedora Update System 2019-04-02 02:13:51 UTC
zorba-3.0.0-44.20140621git152f8964c.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.