Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 169108 - avoid duplicate screensaver preferences
Summary: avoid duplicate screensaver preferences
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-menus
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
: 169109 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-09-23 03:06 UTC by Matthias Clasen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-26 20:28:06 UTC


Attachments (Terms of Use)

Description Matthias Clasen 2005-09-23 03:06:40 UTC
We need to find a way to show only the preferences menu entry for the
screensaver that is running, either xscreensaver or gnome-screensaver,
not both.

Comment 1 Mark McLoughlin 2005-09-26 14:42:43 UTC
*** Bug 169109 has been marked as a duplicate of this bug. ***

Comment 2 Mark McLoughlin 2005-09-26 15:11:57 UTC
Discussed briefly on irc, decided to add a
<MergeDir>/etc/xdg/menus/screensaver-properties-hack/</MergeDir> after the
<Include> in preferences.menu

gnome-screensaver would then install a .menu file in that dir containing
something like:

<Menu>
  <Name>Preferences</Name>
  <Exclude>
    <Filename>xscreensaver-properties.desktop</Filename>
  </Exclude>
</Menu>

Comment 3 Ray Strode [halfline] 2005-09-26 20:28:06 UTC
Should be fixed in tomorrow's rawhide.

Comment 4 Mark McLoughlin 2005-09-27 07:09:53 UTC
Ray: I wouldn't use the preferences-merged dir - that already gets merged in at
a different point, so any .menu files will get merged in twice from there at
different points and could really confuse things.

Comment 5 Ray Strode [halfline] 2005-09-27 15:28:52 UTC
okay this should be fixed tomorrow.

I ended up with the name preferences-post-merged.  In retrospect it's not the
best choice because we would run into a similiar problem if we ever introduced
to a file called preferences-post.menu, but we can change it later if we need to.


Note You need to log in before you can comment on or make changes to this bug.