Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1691039 - F29 to F31 KDE upgrades fail on ruby-irb / rubygem-irb conflict
Summary: F29 to F31 KDE upgrades fail on ruby-irb / rubygem-irb conflict
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ruby
Version: rawhide
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Vít Ondruch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa
: 1691950 (view as bug list)
Depends On:
Blocks: F31BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2019-03-20 17:13 UTC by Adam Williamson
Modified: 2019-03-29 19:19 UTC (History)
10 users (show)

Fixed In Version: ruby-2.6.2-118.fc31 ruby-2.6.2-118.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-29 19:19:38 UTC


Attachments (Terms of Use)

Description Adam Williamson 2019-03-20 17:13:55 UTC
This is rather odd. openQA's test of KDE upgrades from F29 to F31 is failing on a conflict between ruby-irb-2.5.3-100.fc29 and rubygem-irb-1.0.0-117.fc31:

https://openqa.fedoraproject.org/tests/368256#step/upgrade_run/16

"Error: Transaction check error:
  file /usr/share/ruby/irb from install of rubygem-irb-1.0.0-117.fc31.noarch conflicts with file from package ruby-irb-2.5.3-100.fc29.noarch"

however, rubygem-irb-1.0.0-117.fc31 appears to specifically obsolete and provide ruby-irb - https://koji.fedoraproject.org/koji/rpminfo?rpmID=17078674 says:

Provides 	
irb = 1.0.0-117.fc31
ruby(irb) = 2.6.2-117.fc31
ruby-irb = 2.6.2-117.fc31
rubygem(irb) = 1.0.0-117.fc31
rubygem-irb = 1.0.0-117.fc31
Obsoletes 	
ruby-irb < 2.6.2-117.fc31

so I'm really not sure what's going on here, yet. But it's definitely failing...

Comment 1 Adam Williamson 2019-03-20 17:14:49 UTC
As it stands this should be an F31 Beta blocker, per criterion "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from a fully updated, clean default installation of each of the last two stable Fedora releases with that package set installed."

Comment 3 Adam Williamson 2019-03-20 17:18:47 UTC
Oh, forget comment #2, I was getting my versions mixed up - it affects upgrades from both *28* and *29* to 31. 28 to 31 is not a supported case, so we only really have to worry about 29->31.

Comment 4 Mamoru TASAKA 2019-03-21 02:59:16 UTC
This is directory -> symlink change refused by rpm transaction, ref:
https://src.fedoraproject.org/rpms/ruby/c/5aa32e278d096a36ba0d8926d4891f1e0757d4e5?branch=master

Comment 5 Adam Williamson 2019-03-21 14:23:58 UTC
ah, of course, good catch.

Comment 6 Fedora Update System 2019-03-22 12:09:19 UTC
ruby-2.6.2-118.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-95681e73f2

Comment 7 Fedora Update System 2019-03-22 19:17:16 UTC
ruby-2.6.2-118.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-95681e73f2

Comment 8 Artem 2019-03-23 12:09:07 UTC
Successfully upgraded from F29 to F30.

My bugreport: https://bugzilla.redhat.com/show_bug.cgi?id=1691950

Comment 9 Andre Robatino 2019-03-24 15:06:23 UTC
Unfortunately, -118 creates file conflicts when updating in an existing F30 or Rawhide box. See https://bugzilla.redhat.com/show_bug.cgi?id=1691999 and https://bugzilla.redhat.com/show_bug.cgi?id=1692129 .

Comment 10 Mamoru TASAKA 2019-03-24 23:38:26 UTC
-117 was in testing but it was revoked, upgrading from -116 (already in stable) to -118 (in testing) should be okay.

Comment 11 Vít Ondruch 2019-03-25 09:09:18 UTC
*** Bug 1691950 has been marked as a duplicate of this bug. ***

Comment 12 Vít Ondruch 2019-03-25 09:44:14 UTC
(In reply to Andre Robatino from comment #9)
> Unfortunately, -118 creates file conflicts when updating in an existing F30
> or Rawhide box.

Sorry for troubles. This is the troubling directory -> symlink conversion :/


(In reply to Mamoru TASAKA from comment #10)
> -117 was in testing but it was revoked, upgrading from -116 (already in
> stable) to -118 (in testing) should be okay.

I think that the upgrade issues from -117 to -118 has just limited impact, so I hope people can cope with the update. Downgrade to -116 and update to -118 is probably the best option.

Comment 13 Fedora Update System 2019-03-29 19:19:38 UTC
ruby-2.6.2-118.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.