Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1690969 - Request to update the pyOpenSSL package
Summary: Request to update the pyOpenSSL package
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pyOpenSSL
Version: 7.6
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: BaseOS QE Security Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 15:16 UTC by Prathamesh Chavan
Modified: 2019-04-03 09:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-03 09:25:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Prathamesh Chavan 2019-03-20 15:16:56 UTC
1. Proposed title of this feature request
Request to update the pyOpenSSL package



2. Who is the customer behind the request?
Account Name : New York ISO
Account # : 1251416


TAM customer: No


SRM customer: No


Strategic: No



3. What is the nature and description of the request?
>
Update pyOpenSSL rpm package to version 0.15 so ansible can be used to automate tasks company wide.
While community version pyOpenSSL 0.15.1 is available, but customer can only use pyOpenSSL from reputable source such as Red Hat.



4. Why does the customer need this? (List the business requirements here)
>
Customer has a need to use ansible certificate modules to automate tasks for docker such as certificate check/deployment/maintenance, and pyOpenSSL version is too old to let this happen.
Customer also wants to use ansible certificate modules to automatically create certificates, certificate signing request and submit to CA, then check and deploy the returned bundle when building new jboss servers and deploy jboss apps.
Again, while community version pyOpenSSL 0.15.1 is available, but customer can only use signed and supported pyOpenSSL from reputable source such as Red Hat.


5. Is there already an existing RFE in Red Hat Bugzilla?
No



6. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?
>
Soon customer will have Red Hat and its partner help implement automation at NYISO with newly purchased ansible-tower licenses 
Without pyOpenSSL upgraded, this interaction will likely be delayed.



7. Is the sales team involved in this request and do they have any additional input?
>
Sales Team is not involved.



8. Would the customer be able to assist in testing this functionality if implemented?
>
Yes. The customer would be willing to assist in testing this functionality.

Comment 4 RHEL Product and Program Management 2019-03-20 16:21:25 UTC
Development Management has reviewed and declined this request. You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.