Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1690780 - Can't see pipeline builds in project2 When jenkins in project2 and pipeline in project1.
Summary: Can't see pipeline builds in project2 When jenkins in project2 and pipeline...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Gabe Montero
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 08:55 UTC by XiuJuan Wang
Modified: 2019-03-22 07:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-20 17:59:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description XiuJuan Wang 2019-03-20 08:55:34 UTC
Description of problem:
When configured jenkins in project2 and pipeline in project1. Can't see pipeline builds from openshift webconsole and cli side in prpject2. 
But could see pipeline builds in jenkins webconsole of project2.

Version-Release number of selected component (if applicable):

quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:b35a6d15859eca7b27893eb3e0c6e9a2f81b35d3c9c3dfc4eda690fb8dff3a76
openshift-sync-plugin 1.0.34

How reproducible:
always

Steps to Reproduce:
1.Create a pipeline bc without jenkins server in project1.
2.Create jenkins server in project2
3.Configure the OpenShift sync plugin within Jenkins to specify namespace to project1
4. Create a sa with edit role in project1, and add the token to the OpenShift sync plugin within Jenkins
5.Trigger pipeline build from jenkins webconsole.
6.Check builds in project2
7.Check build

Actual results:
5.Could see and trigger the pipeline build in jenkins of project2
6.Can't see pipeline build from openshift webconsole and cli side in project2
7.The pipeline build failed due to "routes.route.openshift.io \"nodejs-mongodb-example\" not found in project2"

Expected results:
Should see the pipeline build from openshift webconsole and cli side in project2

Additional info:

Comment 1 Gabe Montero 2019-03-20 17:59:47 UTC
the pipeline builds are not copied from project1 to project2, so you are not going to see them when viewing project2 from the CLI or console

the sync plugin in jenkins is always operating against project1 in this context, even though jenkins is running in project2

the fact you created the sa/token in project1 and supplied it to sync plugin allows sync plugin to operator against project1

the expected results are incorrect

Comment 2 XiuJuan Wang 2019-03-22 07:28:55 UTC
Thanks, this expect result is totally wrong.


Note You need to log in before you can comment on or make changes to this bug.