Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1690750 - SELinux is preventing modprobe from 'module_load' accesses on the system labeled ipmievd_t.
Summary: SELinux is preventing modprobe from 'module_load' accesses on the system labe...
Keywords:
Status: CLOSED DUPLICATE of bug 1623934
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6c119924bda0088fb4dd5dc8888...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 07:40 UTC by Sandro Bonazzola
Modified: 2019-03-20 08:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-20 08:39:54 UTC


Attachments (Terms of Use)

Description Sandro Bonazzola 2019-03-20 07:40:40 UTC
Description of problem:
SELinux is preventing modprobe from 'module_load' accesses on the system labeled ipmievd_t.

*****  Plugin catchall (100. confidence) suggests   **************************

Se ci credi modprobe dovrebbe essere consentito module_load accesso su system etichettato ipmievd_t per impostazione predefinita.
Then si dovrebbe riportare il problema come bug.
E' possibile generare un modulo di politica locale per consentire questo accesso.
Do
consentire questo accesso per ora eseguendo: # ausearch -c 'modprobe'--raw | audit2allow -M my-$MODULE_NOME # semodule -X 300 -i miei-modprobe.pp

Additional Information:
Source Context                system_u:system_r:ipmievd_t:s0
Target Context                system_u:system_r:ipmievd_t:s0
Target Objects                Unknown [ system ]
Source                        modprobe
Source Path                   modprobe
Port                          <Sconosciuto>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.2-51.fc29.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.20.16-200.fc29.x86_64 #1 SMP Thu
                              Mar 14 15:10:22 UTC 2019 x86_64 x86_64
Alert Count                   72
First Seen                    2019-02-04 07:34:10 CET
Last Seen                     2019-03-20 07:34:13 CET
Local ID                      9e8493a4-26e2-47e1-93f0-3b9af65fc3f4

Raw Audit Messages
type=AVC msg=audit(1553063653.28:139): avc:  denied  { module_load } for  pid=2060 comm="modprobe" scontext=system_u:system_r:ipmievd_t:s0 tcontext=system_u:system_r:ipmievd_t:s0 tclass=system permissive=1


Hash: modprobe,ipmievd_t,ipmievd_t,system,module_load

Version-Release number of selected component:
selinux-policy-3.14.2-51.fc29.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.10.0
hashmarkername: setroubleshoot
kernel:         4.20.16-200.fc29.x86_64
type:           libreport

Potential duplicate: bug 1544604

Comment 1 Zdenek Pytela 2019-03-20 08:39:54 UTC

*** This bug has been marked as a duplicate of bug 1623934 ***


Note You need to log in before you can comment on or make changes to this bug.