Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1690740 - virtio-input-host-pci-transitional doesn't work with rhel6 guest
Summary: virtio-input-host-pci-transitional doesn't work with rhel6 guest
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux Advanced Virtualization
Classification: Red Hat
Component: qemu-kvm
Version: ---
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: 8.0
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 07:05 UTC by liunana
Modified: 2019-04-08 05:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-08 05:25:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description liunana 2019-03-20 07:05:08 UTC
Description of problem:
virtio-input-host-pci-transitional doesn't work with rhel6 guest


Version-Release number of selected component (if applicable):
host: 
    kernel-4.18.0-80.el8.x86_64
    qemu-kvm-3.1.0-20.module+el8+2888+cdc893a8.x86_64

guest:
    kernel-2.6.32-754.el6.x86_64
    version: http://download.eng.pek2.redhat.com/pub/rhel/nightly/RHEL-6.10-20180619.n.0/compose/Server/x86_64/os/ 


How reproducible:
5/5


Steps to Reproduce:

1. boot rhel6 guest with "-device virtio-input-host-pci-transitional,evdev=/dev/input/by-path/pci-0000:00:14.0-usb-0:10:1.0-event-kbd,id=h-kbd,serial=host-keyboard,bus=root2 " , full command [1]

2. type letters with host keyboard,check guest whether can see this letters 
3.


Actual results:
Inside guest can't see any response


Expected results:
Inside guest can see right letters


Additional info:
[1]

/usr/libexec/qemu-kvm \
    -M q35,usb=off -name q35+rhel6 \
    -cpu Skylake-Client-IBRS \
    -serial unix:/tmp/console,server,nowait \
    -nodefaults -rtc base=utc \
    -m 4G \
    -smp 4,sockets=4,cores=1,threads=1 \
    -enable-kvm \
    -device pcie-root-port,id=root0,bus=pcie.0,slot=0 \
    -drive file=/home/a-rhel6-10-180619/rhel6.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,werror=stop,rerror=stop -device virtio-blk-pci-transitional,drive=drive-virtio-disk0,id=virtio-disk0,bus=root0 \
    -boot menu=on \
    -device VGA,id=vga1 \
    -monitor stdio \
    -vnc :0 \
    -device pcie-root-port,id=root1,bus=pcie.0,slot=1 \
    -device virtio-net-pci-transitional,mac=70:5a:0f:38:cd:a5,id=idhRa7sf,vectors=4,netdev=idNIlYmb,bus=root1 -netdev tap,id=idNIlYmb,vhost=on \
    -serial unix:/tmp/console,server,nowait \
    -device pcie-root-port,id=root2,bus=pcie.0,slot=2 \
    -device virtio-input-host-pci-transitional,evdev=/dev/input/by-path/pci-0000:00:14.0-usb-0:10:1.0-event-kbd,id=h-kbd,serial=host-keyboard,bus=root2 \


[2] host information
# tree /dev/input/by-path/
/dev/input/by-path/
├── pci-0000:00:14.0-usb-0:10:1.0-event-kbd -> ../event16
├── pci-0000:00:14.0-usb-0:10:1.1-event -> ../event17
├── pci-0000:00:14.0-usb-0:10:1.1-event-mouse -> ../event19
├── pci-0000:00:14.0-usb-0:9:1.0-event-mouse -> ../event3
├── pci-0000:00:14.0-usb-0:9:1.0-mouse -> ../mouse0
└── platform-pcspkr-event-spkr -> ../event6

Comment 1 Ademar Reis 2019-04-05 18:12:29 UTC
Looks like a problem in the guest driver (do we even have a driver for virtio-input in RHEL6?) and I imagine we can just workaround it by avoiding virtio-input with RHEL6.

Gerd, what's your take on this?

Comment 2 Gerd Hoffmann 2019-04-08 05:25:06 UTC
> do we even have a driver for virtio-input in RHEL6?

No.

And given that virtio-input is virtio-1.0 only and virtio-1.0 support
wasn't backported to RHEL-6 that isn't going to change for sure ...


Note You need to log in before you can comment on or make changes to this bug.