Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1690732 - Variable fonts support
Summary: Variable fonts support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 06:29 UTC by Akira TAGOH
Modified: 2019-03-29 19:19 UTC (History)
6 users (show)

Fixed In Version: libreoffice-6.2.1.2-5.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-29 19:19:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Document Foundation 103596 None None None 2019-03-20 06:31:35 UTC

Description Akira TAGOH 2019-03-20 06:29:47 UTC
Description of problem:
LibreOffice doesn't support Variable fonts.

Version-Release number of selected component (if applicable):
6.2.1.2-1.fc30

How reproducible:
always

Steps to Reproduce:
1.install google-noto-sans-vf-fonts say (make sure if you don't have google-noto-sans-fonts installed because both has same family name)
2.open LO and select Noto Sans
3.type something with bold decoration.

Actual results:
No decorated as bold

Expected results:
should be decorated as bold

Additional info:
There are "variable" property in fontconfig to see if a face is capable for VF and "fontvariations" to see what parameters has variations. those two properties are set only for entire space. but for an instance. an instance looks similar like standalone typefaces.

Comment 1 Caolan McNamara 2019-03-20 08:56:04 UTC
Is there something already existing (using harfbuzz or whatever) where this is already working for comparison ?

Comment 2 Akira TAGOH 2019-03-20 09:11:28 UTC
Pango supports it.

Comment 3 Caolan McNamara 2019-03-20 15:09:58 UTC
For the basic cases of the named variants this should have worked out of the box, but apparently we've outsmarted ourselves and overwritten FC_INDEX in out fontconfig pattern which is getting used to transport that info around.

Comment 4 Caolan McNamara 2019-03-21 12:21:41 UTC
Got something working here

Comment 5 Fedora Update System 2019-03-22 10:18:12 UTC
libreoffice-6.2.1.2-5.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-fe17ded9fe

Comment 6 Fedora Update System 2019-03-22 19:17:09 UTC
libreoffice-6.2.1.2-5.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-fe17ded9fe

Comment 7 Nikolaus Waxweiler 2019-03-24 01:28:14 UTC
Thanks for fixing this, could you backport the fix to 6.1.x and F29, too?

Comment 8 Fedora Update System 2019-03-29 19:19:32 UTC
libreoffice-6.2.1.2-5.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.