Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1690704 - wine: Fantasy Grounds 3.3.7A no longer works with wine-4.3-1.fc29
Summary: wine: Fantasy Grounds 3.3.7A no longer works with wine-4.3-1.fc29
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 29
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 03:31 UTC by Carlos O'Donell
Modified: 2019-03-29 19:18 UTC (History)
3 users (show)

Fixed In Version: wine-4.4-1.fc29 wine-4.4-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-23 02:57:14 UTC


Attachments (Terms of Use)

Description Carlos O'Donell 2019-03-20 03:31:00 UTC
Description of problem:

The Fantasy Grounds II application (https://www.fantasygrounds.com/home/home.php), which is developed with the intent to run under wine, does not work with 4.3, but does work with 4.2/3.16.

Version-Release number of selected component (if applicable):

rpm -qa | grep wine
wine-wingdings-fonts-4.3-1.fc29.noarch
wine-desktop-4.3-1.fc29.noarch
wine-symbol-fonts-4.3-1.fc29.noarch
wine-cms-4.3-1.fc29.x86_64
wine-cms-4.3-1.fc29.i686
wine-core-4.3-1.fc29.x86_64
wine-opencl-4.3-1.fc29.i686
wine-pulseaudio-4.3-1.fc29.i686
wine-courier-fonts-4.3-1.fc29.noarch
wine-filesystem-4.3-1.fc29.noarch
wine-system-fonts-4.3-1.fc29.noarch
wine-capi-4.3-1.fc29.x86_64
wine-fonts-4.3-1.fc29.noarch
wine-ms-sans-serif-fonts-4.3-1.fc29.noarch
wine-opencl-4.3-1.fc29.x86_64
mingw64-wine-gecko-2.47-2.fc26.noarch
wine-twain-4.3-1.fc29.i686
wine-capi-4.3-1.fc29.i686
wine-times-new-roman-fonts-4.3-1.fc29.noarch
wine-common-4.3-1.fc29.noarch
wine-core-4.3-1.fc29.i686
wine-marlett-fonts-4.3-1.fc29.noarch
wine-twain-4.3-1.fc29.x86_64
mingw32-wine-gecko-2.47-2.fc26.noarch
wine-arial-fonts-4.3-1.fc29.noarch
wine-mono-4.8.0-1.fc29.noarch
wine-alsa-4.3-1.fc29.i686
wine-small-fonts-4.3-1.fc29.noarch
wine-ldap-4.3-1.fc29.x86_64
wine-fixedsys-fonts-4.3-1.fc29.noarch
winetricks-20181203-2.fc29.noarch
wine-tahoma-fonts-4.3-1.fc29.noarch
wine-alsa-4.3-1.fc29.x86_64
wine-systemd-4.3-1.fc29.noarch
wine-pulseaudio-4.3-1.fc29.x86_64
[carlos@athas ~]$ rpm -qa | grep wine-core
wine-core-4.3-1.fc29.x86_64
wine-core-4.3-1.fc29.i686

How reproducible:
Remove .wine/
Download the installer:
https://www.fantasygrounds.com/filelibrary/FGWebInstall.exe
wine ./FGWebInstall.exe
[I Agree] (agree to EULA)
[Cross-platform compatibility mode for Linux] (check)
[OK][OK] (skip account setup)
(wait for updater to update itself)
[OK][OK] (skip account setup again for final app udpate)
(app will start after that)

Actual results:
- After installing you get a black window. The cursor works and is drawn correctly, but the window is black.

Expected results:
- After installing you get the properly drawn window (not black).

To restart the application:
cd "/home/user/.wine/dosdevices/c:/Program Files (x86)/Fantasy Grounds"
WINEPREFIX="/home/user/.wine" /usr/bin/wine "C:\\Program Files (x86)\\Fantasy Grounds\\FantasyGrounds.exe"

Additional info:
- dnf downgrade wine to wine 3.16 works. Another laptop with 4.2-2.fc29 also works.

In summary:
wine-4.3-1.fc29 -- FG2 broken.
wine-4.2-2.fc29 -- FG2 works.
wine-3.16-1.fc29 -- FG2 works.

Notes:
FG2 has been working for a long time under Wine:
https://appdb.winehq.org/objectManager.php?sClass=application&iId=3757

Comment 1 Michael Cronenworth 2019-03-20 05:06:14 UTC
We don't do anything fancy in Fedora. Fedora ships wine-staging.

I will package up wine 4.4 now and you can see if that fixes it.

https://koji.fedoraproject.org/koji/buildinfo?buildID=1236129

If it doesn't then you should file an upstream bug and link to it here.

https://bugs.winehq.org/enter_bug.cgi?product=Wine-staging

Comment 2 Carlos O'Donell 2019-03-20 16:01:53 UTC
(In reply to Michael Cronenworth from comment #1)
> We don't do anything fancy in Fedora. Fedora ships wine-staging.
> 
> I will package up wine 4.4 now and you can see if that fixes it.

Testing...

> https://koji.fedoraproject.org/koji/buildinfo?buildID=1236129
> 
> If it doesn't then you should file an upstream bug and link to it here.

This works perfectly.

Clearly something broke in 4.3, and is fixed in 4.4

4.4 works like a charm. Thank you!

Please push as soon as you can.

Comment 3 Fedora Update System 2019-03-20 16:06:22 UTC
wine-4.4-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-eeb6c50dbe

Comment 4 Fedora Update System 2019-03-20 16:07:12 UTC
wine-4.4-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2f8040ecc1

Comment 5 Fedora Update System 2019-03-20 22:02:36 UTC
wine-4.4-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-2f8040ecc1

Comment 6 Fedora Update System 2019-03-21 19:12:15 UTC
wine-4.4-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-eeb6c50dbe

Comment 7 Fedora Update System 2019-03-23 02:57:14 UTC
wine-4.4-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2019-03-29 19:18:40 UTC
wine-4.4-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.