Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1690608 - Update the VDO systemd service file to support thinp bricks
Summary: Update the VDO systemd service file to support thinp bricks
Keywords:
Status: CLOSED DUPLICATE of bug 1634551
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhiv-1.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-19 19:34 UTC by SATHEESARAN
Modified: 2019-03-19 19:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1690606
Environment:
Last Closed: 2019-03-19 19:37:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description SATHEESARAN 2019-03-19 19:34:25 UTC
Description of problem:
------------------------
The current problem with VDO is that when thinpool is created on top of VDO devices, then the discard is not possible, because of the misaligned discard size between thinpool and VDO.

When VDO max_discard_sectors is updated, this problem is solved. So this bug should update the VDO service file and restart VDO service, at the start of the RHHI deployment

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHHI-V 1.6 & RHVH 4.3
RHEL 7.6+
gluster-ansible-roles-1.0.4.4
vdo-6.1.1.125-3.el7.x86_64
kmod-kvdo-6.1.1.125-5.el7.x86_64

How reproducible:
----------------
Not Applicable

Steps to Reproduce:
--------------------
Not Applicable

Actual results:
----------------
systemd unit file vdo service doesn't call out changes for vdo max_discard_sector

Expected results:
-----------------
Drop in the updated VDO systemd unit file as mentioned in the KCS Article[1]

[1] - https://access.redhat.com/solutions/3562021

Comment 1 SATHEESARAN 2019-03-19 19:34:50 UTC
Updated VDO systemd unit file as per https://access.redhat.com/solutions/3562021

[Unit]
Description=VDO volume services
After=systemd-remount-fs.service

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStartPre=/sbin/modprobe -a uds 
ExecStartPre=/sbin/modprobe -a kvdo
ExecStartPre=/bin/sh -c "echo 4096 > /sys/kvdo/max_discard_sectors"
ExecStart=/usr/bin/vdo start --all --confFile /etc/vdoconf.yml
ExecStop=/usr/bin/vdo stop --all --confFile /etc/vdoconf.yml

[Install]
WantedBy=multi-user.target


Once this issue is fixed, cockpit-ovirt should allow creation of thinp bricks on top of VDO devices

Comment 2 SATHEESARAN 2019-03-19 19:37:51 UTC

*** This bug has been marked as a duplicate of bug 1634551 ***


Note You need to log in before you can comment on or make changes to this bug.