Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1690577 - [Beaker 26.3] Adding users and user acls to systems "Access Policy" and hitting the "Save changes" is not always successful
Summary: [Beaker 26.3] Adding users and user acls to systems "Access Policy" and hit...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 26
Hardware: All
OS: Linux
low
low vote
Target Milestone: ---
Assignee: Tomas Klohna šŸ”§
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-19 18:16 UTC by PaulB
Modified: 2019-04-11 08:24 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-11 08:20:51 UTC


Attachments (Terms of Use)

Description PaulB 2019-03-19 18:16:59 UTC
Description of problem:
When you add a user and check the desired acl boxes on the systems 
"Access Policy" page followed by clicking the "Save changes" button -
the changes are not always saved.

I have hit this numerous times. I have tried page refreshing, clicking one box at a time and saving, etc..

Version-Release number of selected component (if applicable):
Beaker 26.3 

How reproducible:
rather consistently

Steps to Reproduce:
1. Add a user and user acls to a Beaker systems "Access policy" and save.
2.
3.

Actual results:
 The changes are quite often not saved.

Expected results:
 The changes are saved.

Additional info:

Comment 1 Tomas Klohna šŸ”§ 2019-03-19 18:49:11 UTC
Hey Paul,
Any specific system where this happens/happened? Because Iā€™m not able to replicate it.

Comment 3 PaulB 2019-03-19 19:30:04 UTC
Tomas,
This issue is not related to any single system.
Many users have experienced this and made mention to me.

Best,
-pbunyan

Comment 4 Anthony Gialluca 2019-03-19 19:41:26 UTC
FYI:
I've noticed that after I go to the ACL page in Beaker. Just prior to making changes I sometimes have to do a 'Shift'-refresh (F5). Then it will take all the changes.

Comment 5 sdoherty 2019-03-19 19:58:41 UTC
I have noticed this as well. Usually if modifying access policy through WebUI, adding a group and the permissions all in one post request is not going to work. I end up having to add a user or group, then save, then refresh before selecting any checkbox. I think that is the work-around that has been consistently ok to deal with.

Comment 6 PaulB 2019-03-19 20:02:38 UTC
All,
So do think this is broken or do I have to do more refreshing??

Best,
-pbunyan

Comment 7 Jeff Bastian 2019-03-19 20:22:41 UTC
Shawn, that method doesn't work for me: I can add a user, but the "Save Change" button is grayed out until I click a checkbox.  (Hmmm, but if I then uncheck the same box, then the "Save Changes" button remains enabled... weird...)

Comment 8 Tomas Klohna šŸ”§ 2019-03-20 08:56:08 UTC
I have been trying to reproduce this all morning and no such luck. Pretty sure I tried close to 40 retries and none of the possible combinations failed.

Out of curiosity. What browser are you all using?

Comment 9 Jeff Bastian 2019-03-20 12:21:25 UTC
I use both Chrome and Firefox equally.  I don't recall if I saw this problem exclusively in one browser, but I can try it in both and see what happens.

Comment 10 Tomas Klohna šŸ”§ 2019-04-11 08:20:51 UTC
I'm closing this issue, because this will be fixed as part of our Web UI Flask migration. I will assign this ticket under correct Epic in Jira, so we can verify it once the migration is done.


Note You need to log in before you can comment on or make changes to this bug.