Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1690007 - Add back the ability to specify labels on the Deploy Image page
Summary: Add back the ability to specify labels on the Deploy Image page
Keywords:
Status: NEW
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Xiaoli Tian
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-18 15:10 UTC by Jan Kleinert
Modified: 2019-04-08 21:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)
example of how it looks in 3.11 (deleted)
2019-03-18 15:10 UTC, Jan Kleinert
no flags Details

Description Jan Kleinert 2019-03-18 15:10:48 UTC
Created attachment 1545344 [details]
example of how it looks in 3.11

Description of problem: I'm not sure if this is an RFE or a regression.

In the web console in 3.11, on the Deploy Image page, it is possible to specify Labels, in addition to Environment Variables.

In the web console on v4, the Deploy Image page only allows the user to specify Environment Variables. There are no fields to add Labels. This means the user must take an additional step to add labels after clicking Deploy.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Select a project in the web console in v4
2. Click the "Add" dropdown and select "Deploy Image"
3. In the "Image Name" field, enter docker.io/openshiftroadshow/parksmap:1.2.0 and click the magnifying glass or press Enter
4. Once the Environment Variables section loads, note that there is not a section to add Labels.


Actual results:

There is a section to add Environment Variables, but no section to add Labels.


Expected results:
I expected a section to add both Environment Variables and Labels, as was the case in 3.11


Additional info: See screenshot of 3.11. 
In our OpenShift starter workshops, adding labels during image deploy is part of the instructions, so this change requires us to modify the workshop for v4 to add additional steps the user needs to take.


Note You need to log in before you can comment on or make changes to this bug.