Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1689654 - Review Request: perl-MooX-Role-Parameterized - Roles with composition parameters
Summary: Review Request: perl-MooX-Role-Parameterized - Roles with composition parameters
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1688688
TreeView+ depends on / blocked
 
Reported: 2019-03-17 11:08 UTC by Emmanuel Seyman
Modified: 2019-04-02 11:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-02 11:19:33 UTC
jplesnik: fedora-review+


Attachments (Terms of Use)

Description Emmanuel Seyman 2019-03-17 11:08:49 UTC
Spec URL: http://people.parinux.org/~seyman/fedora/perl-MooX-Role-Parameterized/perl-MooX-Role-Parameterized.spec
SRPM URL: http://people.parinux.org/~seyman/fedora/perl-MooX-Role-Parameterized/perl-MooX-Role-Parameterized-0.082-1.fc29.src.rpm
Description:
This is an experimental port of MooseX::Role::Parameterized to Moo.
Fedora Account System Username: eseyman
Rpmlint Output: 1 packages and 1 specfiles checked; 0 errors, 0 warnings.

Comment 1 Jitka Plesnikova 2019-03-18 10:34:32 UTC
Source file is ok
Summary is ok
License is ok
Description is ok
URL and Source0 are ok
All tests passed
BuildRequires are ok

$ rpm -qp --requires perl-MooX-Role-Parameterized-0.082-1.fc31.noarch.rpm | sort | uniq -c | grep -v rpmlib
      1 perl(Carp)
      1 perl(Exporter)
      1 perl(List::MoreUtils)
      1 perl(:MODULE_COMPAT_5.28.1)
      1 perl(Module::Runtime)
      1 perl(Moo::Role)
      1 perl(MooX::Role::Parameterized::Proxy)
      1 perl(strict)
      1 perl(warnings)
Binary requires are Ok.

$ rpm -qp --provides perl-MooX-Role-Parameterized-0.082-1.fc31.noarch.rpm | sort | uniq -c
      1 perl(MooX::Role::Parameterized) = 0.082
      1 perl-MooX-Role-Parameterized = 0.082-1.fc31
      1 perl(MooX::Role::Parameterized::Proxy) = 0.082
      1 perl(MooX::Role::Parameterized::With) = 0.082
Binary provides are Ok.

$ rpmlint ./perl-MooX-Role-Parameterized*
2 packages and 1 specfiles checked; 0 errors, 0 warnings.
Rpmlint is ok

The package looks good.
Resolution: Approved

Comment 2 Gwyn Ciesla 2019-03-18 18:57:15 UTC
(fedscm-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/perl-MooX-Role-Parameterized

Comment 3 Emmanuel Seyman 2019-04-02 11:19:33 UTC
The package is now available for F29+. Thank you for the review, Jikta.


Note You need to log in before you can comment on or make changes to this bug.