Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1689396 - undercloud deployment fails with "Error message:\ngiven timezone \"EDT\" is not available""
Summary: undercloud deployment fails with "Error message:\ngiven timezone \"EDT\" is n...
Keywords:
Status: CLOSED DUPLICATE of bug 1688048
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-15 19:49 UTC by Alexander Chuzhoy
Modified: 2019-03-15 19:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-15 19:53:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alexander Chuzhoy 2019-03-15 19:49:50 UTC
undercloud deployment fails with "Error message:\ngiven timezone \"EDT\" is not available""

Environment:
python3-tripleoclient-11.2.1-0.20190313150340.969e01a.el8ost.noarch

[stack@undercloud-0 ~]$ date
Fri Mar 15 15:49:37 EDT 2019



Steps to reproduce:

Try deploy undercloud on a system with time zone set to EDT

Result:

TASK [Set timezone to EDT] *******************************************************************************************************************************************************************
fatal: [undercloud-0]: FAILED! => {"changed": false, "msg": "Error message:\ngiven timezone \"EDT\" is not available"}

NO MORE HOSTS LEFT ***************************************************************************************************************************************************************************

PLAY RECAP ***********************************************************************************************************************************************************************************
undercloud-0               : ok=199  changed=66   unreachable=0    failed=1

Exception: Deployment failed
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/tripleo_deploy.py", line 1256, in _standalone_deploy
    raise exceptions.DeploymentError('Deployment failed')
tripleoclient.exceptions.DeploymentError: Deployment failed
None
Install artifact is located at /home/stack/undercloud-install-20190315191557.tar.bzip2

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Deployment Failed!

ERROR: Heat log files: /var/log/heat-launcher/undercloud_deploy-ioaows1b

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Deployment failed.

Comment 1 Alex Schultz 2019-03-15 19:53:58 UTC

*** This bug has been marked as a duplicate of bug 1688048 ***


Note You need to log in before you can comment on or make changes to this bug.