Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1689364 - Intermittent mount timeouts for secrets and configmaps
Summary: Intermittent mount timeouts for secrets and configmaps
Keywords:
Status: CLOSED DUPLICATE of bug 1583673
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Michal Fojtik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-15 17:42 UTC by Ryan Howe
Modified: 2019-03-15 17:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-15 17:45:28 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ryan Howe 2019-03-15 17:42:11 UTC
Description of problem:

Intermittently seeing multiple deployment/build timeouts with ConfigMaps and/or Secrets failing to mount, after a container has been allocated to a host, for 2-5 minutes.

Version-Release number of selected component (if applicable):
3.9


Additional info:

2 min time out is hit when trying to mount volumes 

   https://github.com/kubernetes/kubernetes/blob/release-1.9/pkg/kubelet/volumemanager/volume_manager.go#L78

kubelet.go:1638] Unable to mount volumes for pod "podname(uid))": timeout expired waiting for volumes to attach/mount for pod "project"/"podname". list of unattached/unmounted volumes=[deployer-token-pz7ch]; skipping pod

Comment 2 Ryan Howe 2019-03-15 17:45:28 UTC

*** This bug has been marked as a duplicate of bug 1583673 ***


Note You need to log in before you can comment on or make changes to this bug.