Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1689329 - new manually installed kernel not appeared in grub2 menu
Summary: new manually installed kernel not appeared in grub2 menu
Keywords:
Status: CLOSED DUPLICATE of bug 1689543
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-15 16:14 UTC by Mikhail
Modified: 2019-03-22 15:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-22 15:28:20 UTC


Attachments (Terms of Use)

Description Mikhail 2019-03-15 16:14:12 UTC
Description of problem:
I am bisecting kernel.
After each iteration i am install new kernel by command:
# make modules_install && make install
After it in grub menu should appears new item, but after second iteration new item not appeared.

# ls -laZ /boot/loader/entries/
total 28
drwx------. 2 root root unconfined_u:object_r:boot_t:s0       4096 Mar 15 20:07 .
drwxrwxr-x. 3 root root unconfined_u:object_r:boot_t:s0       4096 Mar 14 19:58 ..
-rw-r--r--. 1 root root system_u:object_r:modules_object_t:s0  326 Mar 14 19:59 939b591697d2410dbaa1e2c501e4b8b1-0-rescue.conf
-rw-r--r--. 1 root root unconfined_u:object_r:boot_t:s0        336 Mar 14 20:19 939b591697d2410dbaa1e2c501e4b8b1-5.0.0bisect-da2577fe63f8+.conf
-rw-r--r--. 1 root root unconfined_u:object_r:boot_t:s0        336 Mar 15 20:07 939b591697d2410dbaa1e2c501e4b8b1-5.0.0bisect-fb686ad25be0+.conf
-rw-r--r--. 1 root root system_u:object_r:modules_object_t:s0  292 Mar 15 07:41 939b591697d2410dbaa1e2c501e4b8b1-5.1.0-0.rc0.git1.1.fc31.x86_64.conf
-rw-r--r--. 1 root root system_u:object_r:modules_object_t:s0  292 Mar 14 19:58 939b591697d2410dbaa1e2c501e4b8b1-5.1.0-0.rc0.git5.1.fc31.x86_64.conf


# ls -laZ /boot/
total 438192
dr-xr-xr-x.  6 root root system_u:object_r:boot_t:s0            4096 Mar 15 20:08 .
dr-xr-xr-x. 18 root root system_u:object_r:root_t:s0            4096 Mar 14 21:17 ..
-rw-r--r--.  1 root root system_u:object_r:boot_t:s0          203123 Mar  5 22:03 config-5.1.0-0.rc0.git1.1.fc31.x86_64
-rw-r--r--.  1 root root system_u:object_r:boot_t:s0          204544 Mar 11 22:54 config-5.1.0-0.rc0.git5.1.fc31.x86_64
drwx------.  4 root root system_u:object_r:dosfs_t:s0           4096 Jan  1  1970 efi
-rw-r--r--.  1 root root system_u:object_r:boot_t:s0          188476 Feb  5 19:44 elf-memtest86+-5.01
drwxr-xr-x.  2 root root system_u:object_r:boot_t:s0            4096 Mar 13 02:00 extlinux
drwx------.  3 root root system_u:object_r:boot_t:s0            4096 Mar 14 19:58 grub2
-rw-------.  1 root root unconfined_u:object_r:boot_t:s0    73615896 Mar 14 19:58 initramfs-0-rescue-939b591697d2410dbaa1e2c501e4b8b1.img
-rw-------.  1 root root unconfined_u:object_r:boot_t:s0   121319747 Mar 14 20:20 initramfs-5.0.0bisect-da2577fe63f8+.img
-rw-------.  1 root root unconfined_u:object_r:boot_t:s0   126101134 Mar 15 20:08 initramfs-5.0.0bisect-fb686ad25be0+.img
-rw-------.  1 root root unconfined_u:object_r:boot_t:s0    28996065 Mar 15 07:42 initramfs-5.1.0-0.rc0.git1.1.fc31.x86_64.img
-rw-------.  1 root root system_u:object_r:boot_t:s0        30945306 Mar 14 20:00 initramfs-5.1.0-0.rc0.git5.1.fc31.x86_64.img
drwxrwxr-x.  3 root root unconfined_u:object_r:boot_t:s0        4096 Mar 14 19:58 loader
-rw-r--r--.  1 root root system_u:object_r:boot_t:s0          186800 Feb  5 19:44 memtest86+-5.01
lrwxrwxrwx.  1 root root unconfined_u:object_r:boot_t:s0          42 Mar 15 20:07 System.map -> /boot/System.map-5.0.0bisect-fb686ad25be0+
-rw-r--r--.  1 root root unconfined_u:object_r:boot_t:s0     4411279 Mar 14 20:19 System.map-5.0.0bisect-da2577fe63f8+
-rw-r--r--.  1 root root unconfined_u:object_r:boot_t:s0     4410183 Mar 15 20:07 System.map-5.0.0bisect-fb686ad25be0+
-rw-------.  1 root root system_u:object_r:system_map_t:s0   4382491 Mar  5 22:03 System.map-5.1.0-0.rc0.git1.1.fc31.x86_64
-rw-------.  1 root root system_u:object_r:system_map_t:s0   4519526 Mar 11 22:54 System.map-5.1.0-0.rc0.git5.1.fc31.x86_64
lrwxrwxrwx.  1 root root unconfined_u:object_r:boot_t:s0          39 Mar 15 20:07 vmlinuz -> /boot/vmlinuz-5.0.0bisect-fb686ad25be0+
-rwxr-xr-x.  1 root root unconfined_u:object_r:boot_t:s0     9917128 Mar 14 19:59 vmlinuz-0-rescue-939b591697d2410dbaa1e2c501e4b8b1
-rw-r--r--.  1 root root unconfined_u:object_r:boot_t:s0     9791360 Mar 14 20:19 vmlinuz-5.0.0bisect-da2577fe63f8+
-rw-r--r--.  1 root root unconfined_u:object_r:boot_t:s0     9787264 Mar 15 20:07 vmlinuz-5.0.0bisect-fb686ad25be0+
-rwxr-xr-x.  1 root root system_u:object_r:boot_t:s0         9736392 Mar  5 22:03 vmlinuz-5.1.0-0.rc0.git1.1.fc31.x86_64
-rw-r--r--.  1 root root system_u:object_r:boot_t:s0             175 Mar  5 22:00 .vmlinuz-5.1.0-0.rc0.git1.1.fc31.x86_64.hmac
-rwxr-xr-x.  1 root root system_u:object_r:boot_t:s0         9917128 Mar 11 22:54 vmlinuz-5.1.0-0.rc0.git5.1.fc31.x86_64
-rw-r--r--.  1 root root system_u:object_r:boot_t:s0             175 Mar 11 22:51 .vmlinuz-5.1.0-0.rc0.git5.1.fc31.x86_64.hmac


I checked and sure that new files is present in /boot/loader/entries/ and /boot/ directories.

In my case "5.0.0bisect-da2577fe63f8+" appears in boot menu, but item "5.0.0bisect-fb686ad25be0+" is absent.

# rpm -qa | grep grub2 | sort
grub2-common-2.02-72.fc31.noarch
grub2-efi-ia32-2.02-72.fc31.x86_64
grub2-efi-ia32-cdboot-2.02-72.fc31.x86_64
grub2-efi-x64-2.02-72.fc31.x86_64
grub2-efi-x64-cdboot-2.02-72.fc31.x86_64
grub2-pc-2.02-72.fc31.x86_64
grub2-pc-modules-2.02-72.fc31.noarch
grub2-tools-2.02-72.fc31.x86_64
grub2-tools-efi-2.02-72.fc31.x86_64
grub2-tools-extra-2.02-72.fc31.x86_64
grub2-tools-minimal-2.02-72.fc31.x86_64

Comment 1 Javier Martinez Canillas 2019-03-22 15:28:20 UTC
This seems to be a duplicate of bug 1689543 that was fixed by grub2-2.02-74.fc31. Please test with that package version.

*** This bug has been marked as a duplicate of bug 1689543 ***


Note You need to log in before you can comment on or make changes to this bug.