Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1689192 - SELinux is preventing restorecon from 'write' accesses on the file /var/log/pcp/pmlogger/pmlogger_daily-K.log.
Summary: SELinux is preventing restorecon from 'write' accesses on the file /var/log/p...
Keywords:
Status: CLOSED DUPLICATE of bug 1689141
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3189e0ddbf622fa772f863769d9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-15 11:57 UTC by robby.barber2
Modified: 2019-03-15 12:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-15 12:01:44 UTC


Attachments (Terms of Use)

Description robby.barber2 2019-03-15 11:57:56 UTC
Description of problem:
SELinux is preventing restorecon from 'write' accesses on the file /var/log/pcp/pmlogger/pmlogger_daily-K.log.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that restorecon should be allowed write access on the pmlogger_daily-K.log file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'restorecon' --raw | audit2allow -M my-restorecon
# semodule -X 300 -i my-restorecon.pp

Additional Information:
Source Context                system_u:system_r:setfiles_t:s0
Target Context                system_u:object_r:pcp_log_t:s0
Target Objects                /var/log/pcp/pmlogger/pmlogger_daily-K.log [ file
                              ]
Source                        restorecon
Source Path                   restorecon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.1-54.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.20.14-100.fc28.x86_64 #1 SMP Tue
                              Mar 5 19:45:42 UTC 2019 x86_64 x86_64
Alert Count                   2
First Seen                    2019-03-15 06:12:18 CDT
Last Seen                     2019-03-15 06:12:18 CDT
Local ID                      2c8bcd99-ada8-4910-9c19-cf90dead4c71

Raw Audit Messages
type=AVC msg=audit(1552648338.563:224): avc:  denied  { write } for  pid=1787 comm="restorecon" path="/var/log/pcp/pmlogger/pmlogger_daily-K.log" dev="dm-0" ino=612371656 scontext=system_u:system_r:setfiles_t:s0 tcontext=system_u:object_r:pcp_log_t:s0 tclass=file permissive=0


Hash: restorecon,setfiles_t,pcp_log_t,file,write

Version-Release number of selected component:
selinux-policy-3.14.1-54.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.20.14-100.fc28.x86_64
type:           libreport

Potential duplicate: bug 1689141

Comment 1 Zdenek Pytela 2019-03-15 12:01:44 UTC

*** This bug has been marked as a duplicate of bug 1689141 ***


Note You need to log in before you can comment on or make changes to this bug.