Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1689147 - Wrong version of dhcp-libs installed on system.
Summary: Wrong version of dhcp-libs installed on system.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Zhukov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-15 09:49 UTC by Lukas Slebodnik
Modified: 2019-04-05 12:41 UTC (History)
4 users (show)

Fixed In Version: dhcp-4.4.1-11.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-05 12:41:42 UTC


Attachments (Terms of Use)

Description Lukas Slebodnik 2019-03-15 09:49:07 UTC
Description of problem:
It seems that the sub-package dhcp-libs was removed but it is still installed on system as part of dnf upgrade. But this library is not required by anything.
So this sub-pacakge should be probably obsoleted.

Version-Release number of selected component (if applicable):
rpm -q dhcp-client dhcp-libs
dhcp-client-4.4.1-5.fc31.x86_64
dhcp-libs-4.3.6-32.fc30.x86_64

How reproducible:
Deterministic

Steps to Reproduce:
1. docker run -ti --rm registry.fedoraproject.org/fedora:30 bash
# rest executed in container
2. dnf install -e0 -d0 -y dhcp-client fedora-repos-rawhide
3. rpm -q dhcp-client dhcp-libs
4. dnf --disablerepo=* --enablerepo=rawhide --nogpgcheck update -y dhcp\*
5. rpm -q dhcp-client dhcp-libs

Actual results:
[root@host ~]# docker run -ti --rm registry.fedoraproject.org/fedora:30 bash
[root@cb6c8421d2dc /]# dnf install -e0 -d0 -y dhcp-client fedora-repos-rawhide
[root@cb6c8421d2dc /]# rpm -q dhcp-client dhcp-libs
dhcp-client-4.3.6-32.fc30.x86_64
dhcp-libs-4.3.6-32.fc30.x86_64

[root@cb6c8421d2dc /]# dnf --disablerepo=* --enablerepo=rawhide --nogpgcheck update -y dhcp\*
Last metadata expiration check: 0:01:47 ago on Fri 15 Mar 2019 09:43:03 AM UTC.
Dependencies resolved.
================================================================================
 Package            Architecture  Version                  Repository      Size
================================================================================
Upgrading:
 dhcp-client        x86_64        12:4.4.1-5.fc31          rawhide        1.1 M
 dhcp-common        noarch        12:4.4.1-5.fc31          rawhide        135 k

Transaction Summary
================================================================================
Upgrade  2 Packages

Total size: 1.2 M
Downloading Packages:
[SKIPPED] dhcp-client-4.4.1-5.fc31.x86_64.rpm: Already downloaded              
[SKIPPED] dhcp-common-4.4.1-5.fc31.noarch.rpm: Already downloaded              
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Upgrading        : dhcp-common-12:4.4.1-5.fc31.noarch                     1/4 
  Upgrading        : dhcp-client-12:4.4.1-5.fc31.x86_64                     2/4 
  Cleanup          : dhcp-client-12:4.3.6-32.fc30.x86_64                    3/4 
  Cleanup          : dhcp-common-12:4.3.6-32.fc30.noarch                    4/4 
  Running scriptlet: dhcp-common-12:4.3.6-32.fc30.noarch                    4/4 
  Verifying        : dhcp-client-12:4.4.1-5.fc31.x86_64                     1/4 
  Verifying        : dhcp-client-12:4.3.6-32.fc30.x86_64                    2/4 
  Verifying        : dhcp-common-12:4.4.1-5.fc31.noarch                     3/4 
  Verifying        : dhcp-common-12:4.3.6-32.fc30.noarch                    4/4 

Upgraded:
  dhcp-client-12:4.4.1-5.fc31.x86_64     dhcp-common-12:4.4.1-5.fc31.noarch    

Complete!

[root@cb6c8421d2dc /]# rpm -q dhcp-client dhcp-libs
dhcp-client-4.4.1-5.fc31.x86_64
dhcp-libs-4.3.6-32.fc30.x86_64

Expected results:
package dhcp-libs is removed.
//snip
[root@cb6c8421d2dc /]# rpm -q dhcp-client dhcp-libs
dhcp-client-4.4.1-5.fc31.x86_64
package dhcp-libs is not installed

Additional info:

Comment 1 Lukas Slebodnik 2019-03-15 10:25:00 UTC
sh-5.0# rpm -q --provides dhcp-libs
dhcp-libs = 12:4.3.6-32.fc30
dhcp-libs(x86-64) = 12:4.3.6-32.fc30
libdhcpctl.so.0()(64bit)
libomapi.so.0()(64bit)

sh-5.0# dnf repoquery --whatrequires 'libdhcpctl.so.0()(64bit)'
Last metadata expiration check: 0:00:09 ago on Fri 15 Mar 2019 11:24:06 AM CET.
sh-5.0# echo $?
0

sh-5.0# dnf repoquery --whatrequires 'libomapi.so.0()(64bit)'
Last metadata expiration check: 0:00:25 ago on Fri 15 Mar 2019 11:24:06 AM CET.
sh-5.0# echo $?
0

Comment 2 Fedora Update System 2019-03-18 09:57:15 UTC
dhcp-4.4.1-6.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-03eb2cbb92

Comment 3 Fedora Update System 2019-03-18 11:49:41 UTC
dhcp-4.4.1-7.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b4f872a3cc

Comment 4 Lukas Slebodnik 2019-03-21 17:09:01 UTC
It is still broken

[root@host ~]# dnf update dhcp\*
Fedora - Modular Rawhide - Developmental packag  17 kB/s |  17 kB     00:01    
Fedora - Rawhide - Developmental packages for t  13 kB/s |  17 kB     00:01    
Dependencies resolved.
================================================================================
 Package                Architecture Version                Repository     Size
================================================================================
Upgrading:
 dhcp-client            x86_64       12:4.4.1-7.fc31        rawhide       1.1 M
 dhcp-common            noarch       12:4.4.1-7.fc31        rawhide       136 k
 dhcp-libs-static       x86_64       12:4.4.1-7.fc31        rawhide       224 k

Transaction Summary
================================================================================
Upgrade  3 Packages

Total download size: 1.4 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): dhcp-common-4.4.1-7.fc31.noarch.rpm      164 kB/s | 136 kB     00:00    
(2/3): dhcp-libs-static-4.4.1-7.fc31.x86_64.rpm 221 kB/s | 224 kB     00:01    
(3/3): dhcp-client-4.4.1-7.fc31.x86_64.rpm      549 kB/s | 1.1 MB     00:02    
--------------------------------------------------------------------------------
Total                                           484 kB/s | 1.4 MB     00:03     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Upgrading        : dhcp-common-12:4.4.1-7.fc31.noarch                     1/6 
  Upgrading        : dhcp-client-12:4.4.1-7.fc31.x86_64                     2/6 
  Upgrading        : dhcp-libs-static-12:4.4.1-7.fc31.x86_64                3/6 
  Cleanup          : dhcp-client-12:4.4.1-5.fc31.x86_64                     4/6 
  Cleanup          : dhcp-common-12:4.4.1-5.fc31.noarch                     5/6 
  Cleanup          : dhcp-libs-static-12:4.4.1-5.fc31.x86_64                6/6 
  Running scriptlet: dhcp-libs-static-12:4.4.1-5.fc31.x86_64                6/6 
  Verifying        : dhcp-client-12:4.4.1-7.fc31.x86_64                     1/6 
  Verifying        : dhcp-client-12:4.4.1-5.fc31.x86_64                     2/6 
  Verifying        : dhcp-common-12:4.4.1-7.fc31.noarch                     3/6 
  Verifying        : dhcp-common-12:4.4.1-5.fc31.noarch                     4/6 
  Verifying        : dhcp-libs-static-12:4.4.1-7.fc31.x86_64                5/6 
  Verifying        : dhcp-libs-static-12:4.4.1-5.fc31.x86_64                6/6 

Upgraded:
  dhcp-client-12:4.4.1-7.fc31.x86_64        dhcp-common-12:4.4.1-7.fc31.noarch  
  dhcp-libs-static-12:4.4.1-7.fc31.x86_64  

Complete!

[root@host ~]# rpm -qa | grep dhcp
dhcp-libs-static-4.4.1-7.fc31.x86_64
dhcp-client-4.4.1-7.fc31.x86_64
dhcp-common-4.4.1-7.fc31.noarch
dhcp-libs-4.3.6-32.fc30.x86_64

Comment 5 Pavel Zhukov 2019-03-21 17:28:37 UTC
It happens because you have previous version from rawhide installed. Upgrade from stable version (i.e. from dhcp-libs -> ) to rawhide should be ok now. dhcp-libs-static is not obsolete.
This should not happen in case of update from stable version to newest one. Please remove static-libs manually. New installation of rawhide should be OK as well.

Comment 6 Lukas Slebodnik 2019-03-21 21:14:15 UTC
(In reply to Pavel Zhukov from comment #5)
> Please remove static-libs manually. New installation of rawhide should be OK
> as well.

This is unrelated to to this BZ; it is just side effect of terrible packaging changes done in
4.4.1

> It happens because you have previous version from rawhide installed. Upgrade
> from stable version (i.e. from dhcp-libs -> ) to rawhide should be ok now.
> dhcp-libs-static is not obsolete.
> This should not happen in case of update from stable version to newest one.

I did not provide steps to reproduce just to waste my time when creating BZ.
They are there for simple and deterministic testing.

[root@graviton ~]# docker run -ti --rm fedora:29 bash
[root@00ba3285cb78 /]# dnf install -e0 -d0 -y dhcp-client fedora-repos-rawhide
[root@00ba3285cb78 /]# rpm -q dhcp-client dhcp-libs
dhcp-client-4.3.6-29.fc29.x86_64
dhcp-libs-4.3.6-29.fc29.x86_64
[root@00ba3285cb78 /]# dnf --disablerepo=* --enablerepo=rawhide --nogpgcheck update -y dhcp\*
Fedora - Rawhide - Developmental packages for t 466 kB/s |  61 MB     02:14    
Last metadata expiration check: 0:01:29 ago on Thu 21 Mar 2019 09:09:05 PM UTC.
Dependencies resolved.
================================================================================
 Package            Architecture  Version                  Repository      Size
================================================================================
Upgrading:
 dhcp-client        x86_64        12:4.4.1-7.fc31          rawhide        1.1 M
 dhcp-common        noarch        12:4.4.1-7.fc31          rawhide        136 k

Transaction Summary
================================================================================
Upgrade  2 Packages

Total download size: 1.2 M
Downloading Packages:
(1/2): dhcp-common-4.4.1-7.fc31.noarch.rpm       83 kB/s | 136 kB     00:01    
(2/2): dhcp-client-4.4.1-7.fc31.x86_64.rpm      388 kB/s | 1.1 MB     00:02
--------------------------------------------------------------------------------
Total                                           238 kB/s | 1.2 MB     00:05     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Upgrading        : dhcp-common-12:4.4.1-7.fc31.noarch                     1/4 
  Upgrading        : dhcp-client-12:4.4.1-7.fc31.x86_64                     2/4 
  Cleanup          : dhcp-client-12:4.3.6-29.fc29.x86_64                    3/4 
  Cleanup          : dhcp-common-12:4.3.6-29.fc29.noarch                    4/4 
  Running scriptlet: dhcp-common-12:4.3.6-29.fc29.noarch                    4/4 
  Verifying        : dhcp-client-12:4.4.1-7.fc31.x86_64                     1/4 
  Verifying        : dhcp-client-12:4.3.6-29.fc29.x86_64                    2/4 
  Verifying        : dhcp-common-12:4.4.1-7.fc31.noarch                     3/4 
  Verifying        : dhcp-common-12:4.3.6-29.fc29.noarch                    4/4 

Upgraded:
  dhcp-client-12:4.4.1-7.fc31.x86_64     dhcp-common-12:4.4.1-7.fc31.noarch    

Complete!

[root@00ba3285cb78 /]# rpm -q dhcp-client dhcp-libs
dhcp-client-4.4.1-7.fc31.x86_64
dhcp-libs-4.3.6-29.fc29.x86_64

Comment 7 Lukas Slebodnik 2019-03-21 21:18:25 UTC
I would recommend to do some testing before releasing something to fedora.
Or at least ask for review more experienced packagers.

BTW ATM there is higher NVR in koji for fedora30 then for rawhide.
It is not a huge issue; becuase dhcp-4.4.1-8.fc30 has not been pushed to updates testing.

And back to this BZ. It does not work because obsolete was done to wrong part of spec file
https://src.fedoraproject.org/rpms/dhcp/blob/master/f/dhcp.spec#_58
And there is also missing epoch in that obsolete.

sh-5.0# rpm -qa | grep dhcp
dhcp-client-4.4.1-7.fc31.x86_64
dhcp-common-4.4.1-7.fc31.noarch
dhcp-libs-4.3.6-32.fc30.x86_64
sh-5.0# 
sh-5.0# rpm -q --obsoletes dhcp-common-4.4.1-7.fc31.noarch
sh-5.0# rpm -q --obsoletes dhcp-client-4.4.1-7.fc31.x86_64
dhclient < 12:4.4.1-7.fc31

Comment 8 Lukas Slebodnik 2019-04-02 11:06:37 UTC
Still does not work for me.
Have you ever tried to reproduce it yourself ?

[root@host ~]# dnf update dhcp\*
Last metadata expiration check: 0:09:11 ago on Tue 02 Apr 2019 12:55:06 PM CEST.
Dependencies resolved.
================================================================================
 Package            Architecture  Version                  Repository      Size
================================================================================
Upgrading:
 dhcp-client        x86_64        12:4.4.1-8.fc31          rawhide        1.1 M
 dhcp-common        noarch        12:4.4.1-8.fc31          rawhide        136 k

Transaction Summary
================================================================================
Upgrade  2 Packages

Total download size: 1.2 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): dhcp-common-4.4.1-8.fc31.noarch.rpm      4.3 MB/s | 136 kB     00:00    
(2/2): dhcp-client-4.4.1-8.fc31.x86_64.rpm       23 MB/s | 1.1 MB     00:00    
--------------------------------------------------------------------------------
Total                                           1.1 MB/s | 1.2 MB     00:01     Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Upgrading        : dhcp-common-12:4.4.1-8.fc31.noarch                     1/4 
  Upgrading        : dhcp-client-12:4.4.1-8.fc31.x86_64                     2/4 
  Cleanup          : dhcp-client-12:4.4.1-7.fc31.x86_64                     3/4 
  Cleanup          : dhcp-common-12:4.4.1-7.fc31.noarch                     4/4 
  Running scriptlet: dhcp-common-12:4.4.1-7.fc31.noarch                     4/4 
  Verifying        : dhcp-client-12:4.4.1-8.fc31.x86_64                     1/4 
  Verifying        : dhcp-client-12:4.4.1-7.fc31.x86_64                     2/4 
  Verifying        : dhcp-common-12:4.4.1-8.fc31.noarch                     3/4 
  Verifying        : dhcp-common-12:4.4.1-7.fc31.noarch                     4/4 

Upgraded:
  dhcp-client-12:4.4.1-8.fc31.x86_64     dhcp-common-12:4.4.1-8.fc31.noarch    

Complete!



[root@host ~]# rpm -qa dhcp\*
dhcp-common-4.4.1-8.fc31.noarch
dhcp-client-4.4.1-8.fc31.x86_64
dhcp-libs-4.3.6-32.fc30.x86_64

Comment 9 Pavel Zhukov 2019-04-02 11:48:03 UTC
(In reply to Lukas Slebodnik from comment #8)
> Still does not work for me.
> Have you ever tried to reproduce it yourself ?

I did but used wrong tag to build/test https://koji.fedoraproject.org/koji/taskinfo?taskID=33685384. Sorry about that.

Comment 10 Lukas Slebodnik 2019-04-05 12:41:42 UTC
(In reply to Pavel Zhukov from comment #9)
> (In reply to Lukas Slebodnik from comment #8)
> > Still does not work for me.
> > Have you ever tried to reproduce it yourself ?
> 
> I did but used wrong tag to build/test
> https://koji.fedoraproject.org/koji/taskinfo?taskID=33685384. Sorry about
> that.

Works well for me.

And sorry if I was impatient sometimes.


Note You need to log in before you can comment on or make changes to this bug.