Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 168908 - Couldn't display "smb:///" error in nautilus
Summary: Couldn't display "smb:///" error in nautilus
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
: 110674 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-21 06:47 UTC by Mario Bruckschwaiger
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-05 14:42:57 UTC


Attachments (Terms of Use)
samba config file (deleted)
2005-11-03 10:21 UTC, Mario Bruckschwaiger
no flags Details

Description Mario Bruckschwaiger 2005-09-21 06:47:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Description of problem:
When I want to see my Windows network shares I get a "Can't display location" popup with the message "Couldn't display smb:///". Samba mount worked with gnome version 2.10 and samba mount from command line also works.

Version-Release number of selected component (if applicable):
nautilus-2.12.0-1

How reproducible:
Always

Steps to Reproduce:
1. Open Places->Computer with nautilus
2. Select Network
3. Select Windows Network
  

Actual Results:  "Can't display location" popup with "Couldn't display smb:///" message.

Expected Results:  List of computers in the network.

Additional info:

gnome-vfs2-2.12.0-1
gnome-vfs2-smb-2.12.0-1

(all gnome version numbers 2.12.0-1 from development repository)

Comment 1 Marius Andreiana 2005-11-02 11:42:21 UTC
You need to have iptables disabled now in order for samba browsing to work

Comment 2 Mario Bruckschwaiger 2005-11-02 12:27:53 UTC
The service iptables is stopped. Browsing only fails for location "smb:///" but
it works if you directly enter "smb://hostname/share_name".

Comment 3 Marius Andreiana 2005-11-03 10:06:24 UTC
Mario, please attach your /etc/samba/smb.conf

Alex, here's another smb.conf from bug #110674 which appears to be the same as this
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=97573


Comment 4 Alexander Larsson 2005-11-03 10:08:19 UTC
The firewall issue might finally be fixed soon, see bug 113918


Comment 5 Marius Andreiana 2005-11-03 10:09:35 UTC
*** Bug 110674 has been marked as a duplicate of this bug. ***

Comment 6 Mario Bruckschwaiger 2005-11-03 10:21:19 UTC
Created attachment 120682 [details]
samba config file

Here is the smb.conf from the server. I know, it is a SuSE installation. But it
is not browseable from my fedora machine. All Windows machines can browse the
network, and I can browse it with Xffm file manager. I have the same behaviour
with my fedora machine in another network (also SuSE samba server).

Comment 7 Alexander Larsson 2006-09-04 15:21:17 UTC
Do you still see this in FC5?


Comment 8 Mario Bruckschwaiger 2006-09-05 06:20:52 UTC
No, works fine now.


Note You need to log in before you can comment on or make changes to this bug.