Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1689027 - oc get clusterversion should report the old VERSION during upgrade
Summary: oc get clusterversion should report the old VERSION during upgrade
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade
Version: 4.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Abhinav Dahiya
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-15 01:05 UTC by Anurag saxena
Modified: 2019-03-21 05:37 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-19 17:49:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Anurag saxena 2019-03-15 01:05:52 UTC
Description of problem: I believe 'oc get clusterversion' should report old version when the cluster is being upgraded but apparently its reporting the version being upgraded during upgrade process and if the upgrade process stuck the version doesn't rollback to older one


-When the cluster comes up

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-03-13-233958   True        False         6m7s    Cluster version is 4.0.0-0.nightly-2019-03-13-233958

-Doing oc adm upgrade-

$ oc adm upgrade --to-image=registry.svc.ci.openshift.org/ocp/release:4.0.0-0.ci-2019-03-14-150906
Updating to release image registry.svc.ci.openshift.org/ocp/release:4.0.0-0.ci-2019-03-14-150906

# oc get clusterversion  <<<<<<<<<< stuck at this step but the VERSION displayed is not the older one
NAME      VERSION                        AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.ci-2019-03-14-150906   True        True          11m     Working towards 4.0.0-0.ci-2019-03-14-150906: 19% complete


Version-Release number of the following components:
rpm -q openshift-ansible -> package openshift-ansible is not installed
rpm -q ansible -> ansible-2.7.4-1.fc29.noarch
ansible --version -> 2.7.4

How reproducible: Always

Steps to Reproduce:
Run 'oc get clusterversion'

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info: I didn't use playbook to install but just oc adm upgrade

Comment 1 Brenton Leanhardt 2019-03-19 17:49:48 UTC
Hi Anurag,

This is working as designed.  The way to understand the state of the cluster is to read the 'PROGRESSING' and 'STATUS' columns.  It wouldn't really be any more correct to report the old version.  Once you initiate an upgrade the cluster is going to keep working to get there.

Comment 2 Anurag saxena 2019-03-19 18:16:23 UTC
Thanks for clarification, Brenton.


Note You need to log in before you can comment on or make changes to this bug.