Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1688911 - BOINC detects computer is always in use and won't run in certain common conditions
Summary: BOINC detects computer is always in use and won't run in certain common condi...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: boinc-client
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Laurence Field
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-14 17:25 UTC by Scott Williams
Modified: 2019-03-15 09:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-15 09:41:18 UTC


Attachments (Terms of Use)

Description Scott Williams 2019-03-14 17:25:06 UTC
Description of problem:

If the "Suspend when computer is in use" option is used, tasks will never run.  Likewise, if the "Suspend GPU computing when computer is in use", GPU based tasks will never run.  

This is observed on two different Fedora 29 x86_64 installations, both running Gnome with Wayland as a DE.  I have also observed the same behavior on a RHEL 7.6 x86_64 machine with boinc installed via EPEL running Gnome with X.

Other options appear to work as expected, such as suspending by non-BOINC CPU threshold.

Version-Release number of selected component (if applicable):

boinc-client-7.14.2-14.fc29.x86_64
boinc-client-7.14.2-2.el7.x86_64
boinc-manager-7.14.2-14.fc29.x86_64

How reproducible:

Reproducible every time on Fedora 29 and RHEL 7.6.

Steps to Reproduce:
1. Set up BOINC with any active project that pulls work.
2. Select "Suspend when computer is in use" and/or "Suspend GPU computing when computer is in use"
3. Leave the machine idle linger than the defined idle period (default is 3 minutes - I've tested with up to 16 hours of idle)

Actual results:

Tasks will never run.

Expected results:

Tasks should run once defined idle time threshold is met.

Additional info:

This feature works fine with the Android BOINC client.

Comment 1 Germano Massullo 2019-03-15 09:41:18 UTC
Hello, thank you for your bugreport. I am working on this directly on upstream repository because it is a common problem for all Linux platforms.
I cannot provide any specific ETA
https://github.com/BOINC/boinc/issues/1187#issuecomment-225699768

Have a nice day


Note You need to log in before you can comment on or make changes to this bug.