Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1688853 - Bundler 2.0 requires rubygems >= 3.0, but rubygems 2.7 is installed
Summary: Bundler 2.0 requires rubygems >= 3.0, but rubygems 2.7 is installed
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-ruby25
Version: rh-ruby25
Hardware: Unspecified
OS: Unspecified
Target Milestone: alpha
: 3.3
Assignee: Jun Aruga
QA Contact: BaseOS QE - Apps
Depends On:
TreeView+ depends on / blocked
Reported: 2019-03-14 15:23 UTC by Andrew Kofink
Modified: 2019-03-14 18:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2019-03-14 17:49:46 UTC
Target Upstream Version:

Attachments (Terms of Use)

Description Andrew Kofink 2019-03-14 15:23:50 UTC
Description of problem:
rh-ruby25 uses bundler 2.0.1 and rubygems 2.7.6, but bundler 2.0 does not support rubygems < 3.0.0

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. gem --version

Actual results:

Expected results:
Some number >= 3.0.0

Additional info:

I guess bundler doesn't explicitly check or fail if using rubygems < 3.0, but this is certainly an unsupported configuration according to bundler's website.

Comment 2 Vít Ondruch 2019-03-14 17:49:46 UTC
Hi Andrew,

We are shipping rh-ruby25-rubygem-bundler-1.16.1-1.el7 as part of rh-ruby25 collection, so thing should be all right unless you want to give users more information about your use case => Closing the ticket as NOTABUG for now. Feel free to reopen.

Comment 3 Andrew Kofink 2019-03-14 18:28:12 UTC
Oops! Sorry for that oversight.

Note You need to log in before you can comment on or make changes to this bug.