Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1688695 - Unable to update Electron-Cash due to dependency
Summary: Unable to update Electron-Cash due to dependency
Keywords:
Status: ON_QA
Alias: None
Product: Fedora
Classification: Fedora
Component: electron-cash
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jonny Heggheim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1694498
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-14 08:59 UTC by hgbhcprm
Modified: 2019-04-15 13:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description hgbhcprm 2019-03-14 08:59:48 UTC
Description of problem:

I currently have electron-cash-3.3.4-1.fc29.noarch and python3-trezor-0.10.2-2.fc29.noarch installed. When I try to do yum update I get the following conflict

Problem: package electron-cash-3.3.5-3.fc29.noarch conflicts with python3-trezor < 0.11.1 provided by python3-trezor-0.10.2-2.fc29.noarch
  - cannot install the best update candidate for package python3-trezor-0.10.2-2.fc29.noarch
  - cannot install the best update candidate for package electron-cash-3.3.4-1.fc29.noarch


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jonny Heggheim 2019-03-15 09:40:25 UTC
I am able to reproduce. 

The dependency tree also depend on Electrum where the latest version is missing dependencies that are not included in Fedora yet.

Comment 3 hgbhcprm 2019-04-12 11:36:13 UTC
The command "sudo dnf install --enablerepo=updates-testing --advisory=FEDORA-2019-fba8e34603 \*" went fine and outputted in the end 
Installed:
  python3-typing-extensions-3.7.2-1.fc29.noarch

But the command "sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2019-6b71e20508" failed with 
Problem: cannot install the best update candidate for package python3-trezor-0.10.2-2.fc29.noarch
  - nothing provides python-typing-extensions needed by python3-trezor-0.11.2-1.fc29.noarch

There seams to be a mismatch in the names between python and python3

Comment 4 Jonny Heggheim 2019-04-12 21:33:56 UTC
(In reply to hgbhcprm from comment #3)
> The command "sudo dnf install --enablerepo=updates-testing
> --advisory=FEDORA-2019-fba8e34603 \*" went fine and outputted in the end 
> Installed:
>   python3-typing-extensions-3.7.2-1.fc29.noarch
> 
> But the command "sudo dnf upgrade --enablerepo=updates-testing
> --advisory=FEDORA-2019-6b71e20508" failed with 
> Problem: cannot install the best update candidate for package
> python3-trezor-0.10.2-2.fc29.noarch
>   - nothing provides python-typing-extensions needed by
> python3-trezor-0.11.2-1.fc29.noarch
>
> There seams to be a mismatch in the names between python and python3

You are correct + found a missing dependency:

Can you test the new update?
https://bodhi.fedoraproject.org/updates/FEDORA-2019-9187570fbf

Comment 5 hgbhcprm 2019-04-15 13:39:53 UTC
After installing the latest update I was then able to update also electron-cash. Thanks


Note You need to log in before you can comment on or make changes to this bug.