Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1688336 - Packaging `expect` binary in `whois-mkpasswd` package breaks testing
Summary: Packaging `expect` binary in `whois-mkpasswd` package breaks testing
Keywords:
Status: CLOSED DUPLICATE of bug 1687870
Alias: None
Product: Fedora
Classification: Fedora
Component: whois
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 15:01 UTC by Siteshwar Vashisht
Modified: 2019-03-14 08:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-14 08:39:48 UTC


Attachments (Terms of Use)

Description Siteshwar Vashisht 2019-03-13 15:01:42 UTC
Description of problem:
Some packages uses `expect` utility to test commandline tools. Packaging `expect` in whois package breaks testing of such packages. For e.g. It broke testing of ksh package in upstream https://api.travis-ci.org/v3/job/505796870/log.txt

Version-Release number of selected component (if applicable):
whois-mkpasswd-5.4.1-1.fc29.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Try to install `expect` when `whois-mkpasswd` package is installed.

Actual results:
Problem: problem with installed package whois-mkpasswd-5.4.1-1.fc29.x86_64
  - package whois-mkpasswd-5.4.1-1.fc29.x86_64 conflicts with expect provided by expect-5.45.4-5.fc29.x86_64
  - conflicting requests

Expected results:
Installing `expect` should work.

Additional info:
It was probably broken by https://src.fedoraproject.org/rpms/whois/c/21c39d87faeabf0548a2530fc61f2abbd42abee0?branch=f29

We are using f29 docker image to do our builds and `whois-mkpasswd` is installed by default on these images.

Comment 1 Petr Pisar 2019-03-14 08:39:48 UTC

*** This bug has been marked as a duplicate of bug 1687870 ***


Note You need to log in before you can comment on or make changes to this bug.