Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1688220 - Please consider introducing the mongodb collectd plugin
Summary: Please consider introducing the mongodb collectd plugin
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: collectd
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Ruben Kerkhof
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 11:17 UTC by Andrea Veri
Modified: 2019-03-13 12:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-13 11:59:12 UTC


Attachments (Terms of Use)

Description Andrea Veri 2019-03-13 11:17:10 UTC
The mongodb collectd plugin is currently not being shipped in EPEL and I believe that's related to the fact the "official" module hasn't seen an update since 2012 (according to [1]). The question here would be whether the collectd maintainer would evaluate to introduce the fixed and confirmed working module from the Stackdriver team as reported in [2], [3].

Thanks in advance!


[1] https://collectd.org/wiki/index.php/Plugin:MongoDB
[2] https://cloud.google.com/monitoring/agent/plugins/mongodb
[3] https://clinta.github.io/mongodb-for-collectd

Comment 1 Ruben Kerkhof 2019-03-13 11:59:12 UTC
No sorry, I'm not going to get code from a third party repo and add it to collectd, certainly not in an stable version such as the one in EPEL.
If you'd like to see this supported better ask the Stackdriver team to push their changes upstream.

Comment 2 Andrea Veri 2019-03-13 12:15:31 UTC
Just FYI: https://github.com/Stackdriver/collectd/issues/145, thanks!


Note You need to log in before you can comment on or make changes to this bug.