Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1688158 - It is better to show the update progress on the overview tab in Cluster Settings page
Summary: It is better to show the update progress on the overview tab in Cluster Setti...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.1.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 10:04 UTC by shahan
Modified: 2019-03-19 17:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-19 17:25:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description shahan 2019-03-13 10:04:48 UTC
Description of problem:
 It is better to show the update progress on the overview tab in Cluster Settings page while CLI does.

Version-Release number of selected component (if applicable):
cluster version: 4.0.0-0.nightly-2019-03-05-045224
console commit: 24942e86dd5bef0b17c1e33bfcd386b450c49b19

How reproducible:
Always

Steps to Reproduce:
1. Upgrade cluster on web console, check the Cluster Settings page
2. $ oc get clusterversions.config.openshift.io
3.

Actual results:
1. Always showing 'updating' for 'Update Status' on the overview tab
2. $ oc get clusterversions.config.openshift.io
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-03-05-045224   True        True          13m     Working towards 4.0.0-0.nightly-2019-03-05-045224: 22% complete

Expected results:
It better to show the progress for the upgrade

Additional info:

Comment 1 Samuel Padgett 2019-03-13 12:43:32 UTC
This should have been added as part of https://github.com/openshift/console/pull/1183

Can you if the build you are testing has this change?

Comment 2 shahan 2019-03-14 07:09:08 UTC
It will show the progress when uprading cluster, such as  "Cluster update in progress. Working towards 0.0.1-2019-03-14-054235: 28% complete. View Cluster Operators for more details. "
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:1c8b428f9934d9cde7b8998dc4586ad045085aa452e2cb749b9b80e71d7de183


Note You need to log in before you can comment on or make changes to this bug.