Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1688117 - qemu-block-rbd error while running dnf system-upgrade to F30
Summary: qemu-block-rbd error while running dnf system-upgrade to F30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 07:32 UTC by Matt Fagnani
Modified: 2019-03-21 12:41 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-21 11:51:13 UTC


Attachments (Terms of Use)

Description Matt Fagnani 2019-03-13 07:32:13 UTC
Description of problem:

I got an error involving qemu-block-rbd while running dnf system-upgrade to F30.

Problem 3: package qemu-block-rbd-2:3.0.0-3.fc29.i686 requires libcapstone.so.3, but none of the providers can be installed
  - capstone-3.0.5-2.fc29.i686 does not belong to a distupgrade repository
  - problem with installed package qemu-block-rbd-2:3.0.0-3.fc29.i686

I have many of the qemu i686 packages installed. 

sudo dnf system-upgrade download --refresh --releasever=30 --skip-broken --allowerasing showed qemu-block-rbd being removed:

Removing dependent packages:
...
qemu-block-rbd      i686   2:3.0.0-3.fc29           @updates-testing  31 k


Version-Release number of selected component (if applicable):
qemu-block-rbd-2:3.0.0-3.fc29.i686
qemu-3.1.0-4.fc30.3
capstone-3.0.5-2.fc29.i686
capstone-4.0.1-3.fc30

How reproducible:
5 of 5 times

Steps to Reproduce:
In F29 with updates-testing enabled and qemu-block-rbd-2:3.0.0-3.fc29.i686 installed
1. sudo dnf upgrade --refresh
2. sudo dnf system-upgrade download --refresh --releasever=30
3. sudo dnf system-upgrade download --refresh --releasever=30 --skip-broken --allowerasing

Actual results:
dnf system-upgrade error involving qemu-block-rbd

Expected results:
no error

Additional info:

qemu-3.1.0-4.fc30.3's changelog on koji noted the following. 
* Mon Dec 10 2018 Daniel P. Berrangé <berrange@redhat.com> - 2:3.1.0-0.2.rc1 - Disable RBD on 32-bit arches
https://koji.fedoraproject.org/koji/buildinfo?buildID=1219349

Obsoleting qemu-block-rbd on 32-bit architectures might prevent this error if it isn't going to be built again for them. capstone-4.0.1-3.fc30 provides libcapstone.so.4, but keeping qemu-block-rbd-2:3.0.0-3.fc29 might conflict since it requires libcapstone.so.3.

Comment 1 Daniel Berrange 2019-03-19 13:05:38 UTC
Pushed a PoC that makes qemu-common obsolete qemu-block-rbd to attempt to fix this problem here:

https://src.fedoraproject.org/rpms/qemu/pull-request/6

Comment 2 Daniel Berrange 2019-03-21 11:51:13 UTC
Should be fixed in 4.0.0-0.2.rc0

Comment 3 Cole Robinson 2019-03-21 12:41:18 UTC
FYI I'm building these changes for f30 as well


Note You need to log in before you can comment on or make changes to this bug.