Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1688106 - Remove implementation of number of files opened in posix xlator
Summary: Remove implementation of number of files opened in posix xlator
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 07:13 UTC by Pranith Kumar K
Modified: 2019-03-14 04:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-14 04:48:36 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22333 None Merged storage/posix: Remove nr_files usage 2019-03-14 04:48:35 UTC

Description Pranith Kumar K 2019-03-13 07:13:45 UTC
Description of problem:
nr_files is supposed to represent the number of files opened in posix.
Present logic doesn't seem to handle anon-fds because of which the
counts would always be wrong.
    
I don't remember anyone using this value in debugging any problem probably
because we always have 'ls -l /proc/<pid>/fd' which not only prints the
fds that are active but also prints their paths. It also handles directories
and anon-fds which actually opened the file. So it is better to remove this code instead of fixing the buggy logic to have the nr_files.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2019-03-13 08:29:46 UTC
REVIEW: https://review.gluster.org/22333 (storage/posix: Remove nr_files usage) posted (#2) for review on master by Pranith Kumar Karampuri

Comment 2 Worker Ant 2019-03-14 04:48:36 UTC
REVIEW: https://review.gluster.org/22333 (storage/posix: Remove nr_files usage) merged (#3) on master by Amar Tumballi


Note You need to log in before you can comment on or make changes to this bug.