Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1688105 - Error involving python2-rpkg running dnf system-upgrade to F30
Summary: Error involving python2-rpkg running dnf system-upgrade to F30
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpkg
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: cqi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 07:04 UTC by Matt Fagnani
Modified: 2019-04-16 06:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-16 06:30:40 UTC


Attachments (Terms of Use)

Description Matt Fagnani 2019-03-13 07:04:42 UTC
Description of problem:

While I was testing upgrading from F29 to F30, I got the following dnf system-upgrade error involving python2-rpkg

Problem 2: package python2-rpkg-1.57-6.fc29.noarch requires rpkg-common = 1.57-6.fc29, but none of the providers can be installed
  - rpkg-common-1.57-6.fc29.noarch does not belong to a distupgrade repository
  - problem with installed package python2-rpkg-1.57-6.fc29.noarch

rpkg's changelog on koji showed that python2-rpkg was disabled on F30+ 

* Mon Feb 04 2019 Lubomír Sedlář <lsedlar@redhat.com> - 1.57-4 - Disable Py2 package on F30+

Obsoleting python2-rpkg on F30+ might prevent the error if it isn't going to be built again on F30+. 

sudo dnf system-upgrade download --refresh --releasever=30 --skip-broken --allowerasing showed python2-rpkg being removed.

Removing dependent packages:
...
python2-rpkg    noarch 1.57-6.fc29       @updates-testing  620 k

Version-Release number of selected component (if applicable):
rpkg-1.57-6.fc30
python2-rpkg-1.57-6.fc29.noarch

How reproducible:
5 of 5 times

Steps to Reproduce:
In F29 with updates-testing enabled and python2-rpkg installed
1. sudo dnf upgrade --refresh 
2. sudo dnf system-upgrade download --refresh --releasever=30
3. sudo dnf system-upgrade download --refresh --releasever=30 --skip-broken --allowerasing

Actual results:
dnf system-upgrade to F30 resulted in an error involving python2-rpkg

Expected results:
no dnf error

Additional info:

This python2-rkg error was noted by Sergio Durigan Junior at
https://bugzilla.redhat.com/show_bug.cgi?id=1656509#c27

The error was mentioned by a few people at
https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/D4ZBMUAOS63DFEKS4J35EQP5P7VVTPMM/#2WSPKXMAFDB7MUTLPJ6ORWQHHTY3LBJK

I couldn't find a report filed for the rpkg component.

Comment 1 Ondřej Nosek 2019-03-13 12:44:20 UTC
Thanks for your report.

Comment 2 Matt Fagnani 2019-03-17 06:10:13 UTC
I don't see this python2-rpkg error now since fedora-obsolete-packages-30-30 obsoleted python2-rpkg < 1.57-7.
https://koji.fedoraproject.org/koji/buildinfo?buildID=1219988  Thanks.


Note You need to log in before you can comment on or make changes to this bug.