Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1688038 - openstack undercloud install fails with FileNotFoundError: [Errno 2] No such file or directory: 'python': 'python'
Summary: openstack undercloud install fails with FileNotFoundError: [Errno 2] No such ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 00:18 UTC by Yuri Obshansky
Modified: 2019-03-15 18:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-15 18:07:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yuri Obshansky 2019-03-13 00:18:21 UTC
Description of problem:
openstack undercloud install fails with FileNotFoundError: [Errno 2] No such file or directory: 'python': 'python'

[stack@site-undercloud-0 ~]$ cat install-undercloud.log 
2019-03-12 19:50:32.037 8949 INFO tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] Checking Hostname...
2019-03-12 19:50:32.151 8949 INFO tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] Checking Memory...
2019-03-12 19:50:32.151 8949 INFO tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] Checking Disk space...
2019-03-12 19:50:37.057 8949 INFO tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] Checking Sysctl...
2019-03-12 19:50:37.057 8949 INFO tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] Checking Password file...
2019-03-12 19:50:37.057 8949 INFO tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] Checking Deprecated now invalid options...
2019-03-12 19:50:37.058 8949 INFO tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] Checking Custom env file...
2019-03-12 19:50:37.061 8949 ERROR tripleoclient.v1.undercloud.InstallUndercloud [  ] Exception occured while running the command
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/tripleoclient/command.py", line 29, in run
    super(Command, self).run(parsed_args)
  File "/usr/lib/python3.6/site-packages/osc_lib/command/command.py", line 41, in run
    return super(Command, self).run(parsed_args)
  File "/usr/lib/python3.6/site-packages/cliff/command.py", line 184, in run
    return_code = self.take_action(parsed_args) or 0
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/undercloud.py", line 128, in take_action
    dry_run=parsed_args.dry_run)
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/undercloud_config.py", line 687, in prepare_undercloud_deploy
    undercloud_preflight.check(verbose_level, upgrade)
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/undercloud_preflight.py", line 476, in check
    _validate_env_files_paths()
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/undercloud_preflight.py", line 357, in _validate_env_files_paths
    name='process-templates-dry-run', cwd=tht_path, wait=False)
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/undercloud_preflight.py", line 60, in _run_live_command
    universal_newlines=True)
  File "/usr/lib64/python3.6/subprocess.py", line 729, in __init__
    restore_signals, start_new_session)
  File "/usr/lib64/python3.6/subprocess.py", line 1364, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: 'python': 'python'


Version-Release number of selected component (if applicable):
[stack@site-undercloud-0 ~]$ rpm -qa "*tripleoclient*"
python3-tripleoclient-heat-installer-11.2.1-0.20190311200333.5130991.el8ost.noarch
python3-tripleoclient-11.2.1-0.20190311200333.5130991.el8ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. openstack undercloud install 

Actual results:
FileNotFoundError: [Errno 2] No such file or directory: 'python': 'python'

Expected results:
No failures

Additional info:

Comment 1 Yuri Obshansky 2019-03-15 18:07:22 UTC
This is not a bug, 
Happened due the incorrect undercloud.conf template.
Please, close it
Thank you
Yuri


Note You need to log in before you can comment on or make changes to this bug.